Not sure if this is normal, or if I'm doing something wrong.

andrewd0andrewd0 Posts: 28
edited December 1969 in New Users

Daz3d slows to a crawl when I'm working on a scene with more than two or three characters. Even with no lighting and everything hidden but the character I'm trying to manipulate, the program will freeze for a few minutes every time I attempt to change anything. It's gotten to where simply making this guy face the direction I want him to requires dragging the Y rotate slider (I can't tell how far I'm dragging it because everything freezes up the second I do), and going to get something drink, checking the mail, etc., coming back and hoping it's in the right spot once it's unfrozen.

Is Daz not designed to handle more than a few characters at once (this scene has 6, and I haven't added any sort of background, props, etc), or am I screwing something up on my end to break it?

Comments

  • SzarkSzark Posts: 8,765
    edited December 2012

    Without details like what version of Daz Studio exactly you have and what your system specs are we can't really help much.

    On my 3GB RAM 32 bit Vista, 3 characters would do the same thing.

    DS4 had problems like this but I have found DS4.5.1.6 so much better and responsive.

    and just for future reference DAZ3D is the company, Daz Studio is the softwware. ;)

    Post edited by Szark on
  • andrewd0andrewd0 Posts: 28
    edited December 1969

    Ah, sorry, heh.

    I'm running Windows 7 (64 bit) on an i7 with 8gb of RAM and a GTX 580 with 1.5gb of VRAM. I'm using Daz Studio 4.5.1.6 Pro. The scene in question had a blank blue background and six humans with about four or five articles of clothing each, including hair. I'm still at the stage where I'm experimenting with manipulating the models' joints and messing around with morphs (Genesis is awesome), so the idea behind this image was to give myself sort of a frame of reference for how certain morphs compare proportionately.

    I had them all invisible but the one I was trying to move, and it was a little sluggish but not terrible until the last one. I could move the viewport just fine once everything unfroze, but messing with the dials shut it down.

    If this is just how it works, then I'll find a work-around. I know people can render images with more going on that that, and that means they have to build them somehow, heh.

  • SzarkSzark Posts: 8,765
    edited December 1969

    WoW 6 characters. The biggest memeory drain are textures and most textures there days are huge. Reducing the size in PS/GIMP etc will help but never having a 64bit system I couldn't say whether 6 characters is the limit.

  • scorpioscorpio Posts: 3,785
    edited December 2012

    It could also be the smoothing modifyer updating.

    6 figures is about the max for me to work with, but I have a low spec graphics card and not an i7, but do have 64bit and 8GB ram.

    Post edited by scorpio on
  • Scott LivingstonScott Livingston Posts: 4,104
    edited December 2012

    I've rendered nine at once...on a 64-bit single-core with only 3GB RAM...so it's possible...but it sure was painful! (See image...no postwork except adding the backdrop). I used a set and a few other figures (birds), but only one or two articles of clothing per character.

    Most people would probably recommend rendering this type of scene in several passes, then compositing them together in post. I think I'll try it that way next time.

    lantios_3.jpg
    1000 x 562 - 479K
    Post edited by Scott Livingston on
  • JaderailJaderail Posts: 0
    edited December 1969

    It could also be the smoothing modifyer updating.

    6 figures is about the max for me to work with, but I have a low spec graphics card and not an i7, but do have 64bit and 8GB ram.

    I agree, the smoothing modifer is what is hanging up the PC as you work.

  • sikeussikeus Posts: 0
    edited December 2012

    It could also be the smoothing modifyer updating.

    6 figures is about the max for me to work with, but I have a low spec graphics card and not an i7, but do have 64bit and 8GB ram.

    I have similar specs as yours, except I have 16 gb of RAM. I just assembled a quick scene with 6 figures and an environment. A look at my RAM shows 6.19 GB in use, and my environment isn't very intense. So you may be running into your RAM limit.

    With six figures loaded into the scene, my viewport is starting to noticeably slow down. That may mean that the amount of textures in the scene are starting to max out my VRAM on my GTX 580.

    I don't know if instancing will work in this case, since I've never used it myself, but I've heard that it helps reduce the memory load.

    Edit: I didn't mess with the smoothing modifier at all, but it's on because I've used Genesis clothing. It's definitely contributing to the slow down.

    Post edited by sikeus on
  • andrewd0andrewd0 Posts: 28
    edited December 1969

    Cool, thanks everyone. I was worried that I broke something, but it sounds like I was just being a n00b. From now on I'll be working with naked grey people until it's time to render..

  • sikeussikeus Posts: 0
    edited December 1969

    You may want to try selecting all of your clothing items instead, all at once, and then going to the parameters-->general-->mesh smoothing tab. If you turn enable smoothing and interactive update off, that should stop the smoothing modifier. Then, when you're ready with a finished scene, turn it back on. I just experimented with a hideous combination of shapes to confirm that those steps do indeed first stop, then start the smoothing modifier.

  • SzarkSzark Posts: 8,765
    edited December 1969

    thx guys for chipping in here. I have learnt that when it is my turn to upgrade go for 16 GB or go Ultimate with 32 GB of RAM...yeah baby. :) Nice GC for the Open GL aspects and as many cores as I can afford.

  • mark128mark128 Posts: 883
    edited December 1969

    I did a scene with 10 genesis figures and 5 v4 figures. I have a Win 7 (64 bit) system with 16gb of ram and a GT640 graphics card. DAZ definitely did slow down, but I could still work with the scene. The automatic clothing smoothing certainly was part of what slowed the scene down. As I remember DAZ was using 6 or 7gb of RAM when editing and up to 10gb while rendering, so I think this would have been impossible or incredibly painful on a machine with only 8gb.

    You should use the task manager on windows to check your RAM usage. There may be some other application or process running on your computer that is using a lot of memory. If you are working with a big scene, shut down all the other applications you don't need.

    When working with big scenes you have to do a lot of test renders to get the lighting correct. I always turn off all the hair when making those renders to tweak the lighting. Hair definitely increases the render time, sometimes by a lot, depending on what hair you are using. You should be using the spot render tool for tweaking lighting as much as possible before rendering the whole scene.

  • Miss BMiss B Posts: 3,069
    edited December 1969

    I agree with mark. Not only does hair have intensive textures, but also raytracing shadows (which is highly recommended for hair), will really push the limits of any system. Depending on how close the characters are to the camera, I recommend turning off cast shadows on all the hair, and you should see a significant difference.

  • andrewd0andrewd0 Posts: 28
    edited December 1969

    I just went back in to the same scene and deleted all of the clothing and hair and removed all the textures. Sure enough, the controls remained pretty responsive even going up to 10 characters. It had to have been the smoothing and textures slowing everything down.

    I'm not really playing with lighting yet, but I kind of dread it.

Sign In or Register to comment.
Rocket Fuel