Categories Disappearing

Geminii23Geminii23 Posts: 590
edited December 1969 in New Users

So I am having a weird problem with the SmartContent tabs. When I first load up DAZ the Environments, Scenes and Sets are all visible briefly. Once the scene loads the default character the tabs vanish.

I have tried resetting the DB and then doing a reimport of the metadata and things worked briefly but then DAZ crashed and the problem resurfaced. I have also tried deleting the Database files from (on MAC) library/DAZ3D/Content Management Service/databases.

Any help would be good. I have a lot of content since Black Friday and would hate to have to reinstall everything from scratch.

Comments

  • mjc1016mjc1016 Posts: 7,732
    edited December 1969

    Just because Smart Content messes up doesn't mean you need to reinstall your content...in fact, it probably won't change all that much.

    First off, is the Content Management System actually running?

    Without that service running in the background, Smart Content/Categories and the like won't work.

    Next, does the content still show up in the Content Library?

  • Geminii23Geminii23 Posts: 590
    edited December 1969

    mjc1016 said:
    Just because Smart Content messes up doesn't mean you need to reinstall your content...in fact, it probably won't change all that much.

    First off, is the Content Management System actually running?

    Without that service running in the background, Smart Content/Categories and the like won't work.

    Next, does the content still show up in the Content Library?

    I have verified that the Content Management System is running via Activity Monitor on MAC. Not all the content shows in the Content Library on the Right side. I think only the v4 compatible content shows.

  • mjc1016mjc1016 Posts: 7,732
    edited December 1969

    Geminii23 said:
    mjc1016 said:
    Just because Smart Content messes up doesn't mean you need to reinstall your content...in fact, it probably won't change all that much.

    First off, is the Content Management System actually running?

    Without that service running in the background, Smart Content/Categories and the like won't work.

    Next, does the content still show up in the Content Library?

    I have verified that the Content Management System is running via Activity Monitor on MAC. Not all the content shows in the Content Library on the Right side. I think only the v4 compatible content shows.

    Use Finder and look for the content...it's either a nested folder/duplicate folder or an install went wrong and overwrote everything, as opposed to merging.

  • Geminii23Geminii23 Posts: 590
    edited December 1969

    In exploring My Library, I did see one thing that seems odd.

    In the Runtime folder I see another Runtime folder inside that only has Geometries, Libraries, etc related to Stonemason GSFC P4, P5 and PP.

    So in effect these seem to be nested and possibly duplicated.

    runtime.jpg
    813 x 860 - 201K
  • FixmypcmikeFixmypcmike Posts: 12,154
    edited December 1969

    The Runtime folder embedded inside another is a problem -- you need to move everything inside that second Runtime up into the first runtime. However, that's not related to what you're seeing in Smart Content. When something in your scene is selected, Smart Content only displays items that are compatible with it, which is why things like sets and architecture do not appear when Genesis is loaded. Click in the viewport away from Genesis so that it isn't selected and you'll see all the Smart Content categories.

  • Geminii23Geminii23 Posts: 590
    edited December 1969

    The Runtime folder embedded inside another is a problem -- you need to move everything inside that second Runtime up into the first runtime. However, that's not related to what you're seeing in Smart Content. When something in your scene is selected, Smart Content only displays items that are compatible with it, which is why things like sets and architecture do not appear when Genesis is loaded. Click in the viewport away from Genesis so that it isn't selected and you'll see all the Smart Content categories.

    LOL

    I feel a bit stupid now. Yes when I select around to different items in my scene the Smart Content (apparently very Smart) hides and reveals only what is applicable.

    I actually also discovered how the extra Runtime appeared. After completing removing everything related to the Generic SciFi Corridor, I found that the left over runtime folder (which only contained info related to this pack as well) was actually installed accidentally using the Poser installers. Doh!

    Thanks for all the help!

Sign In or Register to comment.
Rocket Fuel