DAZ Studio Pro BETA, version 4.5.1.41, is now available!

DAZ_BrianDAZ_Brian Posts: 179
edited December 2012 in DAZ Studio Discussion

DAZ 3D is pleased to announce the next public version of the DAZ Studio Pro BETA - version 4.5.1.41!

What is a BETA?

Despite our best efforts, DAZ 3D cannot possibly test the software under all possible conditions. So, we are providing this version of the application to the general public in order to uncover problems that were not discovered during internal testing. We expect that there will still be problems and we hope that when users encounter any problems, they will report them to the Bug Tracker so that they can be validated, prioritized and fixed.

As with any software classified as being in the BETA phase of development, you should expect to encounter bugs. Any bugs you do encounter while using BETA software can vary in terms of severity, from minor features that do not work correctly to problems that cause your computer to crash. Before choosing to use BETA software for production purposes, you should decide whether the benefit of new features and bug fixes provided by the BETA version outweighs the risk of instability you may encounter.

What is new in this version? Do I need to update my copy?

The 4.5.1.41 version resolves several issues and implements many improvements since the 4.5.1.6 General Release. More detail on specific fixes/changes/improvements can be found in the Change Log, which can be viewed online within the Documentation Center portion of our site. All new downloads of the DAZ Studio Pro BETA product (SKU: 12000) will be of this version.

The highlights are:

1) Fixed crash when loading dynamic clothing that has a material applied to it.

2) Fixed Transfer Utility to not remove unused bones if not projecting weights.

3) Extended Filter Weights to allow filtering of multiple maps at the same time.

4) Updated 3Delight libraries to version 10.0.70. For details see 3Delight change log here


Has the Genesis Starter Essentials content been updated too?

Yes, the Genesis Starter Essentials content that is provided with the product has been updated to version 1.9.
- Changed min/max values on scale properties to 0.001/1000
- Merged metadata into one product
- Changed uberEnvironment Occlusion Samples Max Limit to 512
- Changed uberEnvironment Maximum Trace Distance default to 150
- Some files were moved from Genesis Starter Essentials to DAZ Studio

NOTE: If you are NOT updating to this version of DAZ Studio Pro, do NOT update your version of Genesis Starter Essentials

How do I get the latest version?

If you have previously added the DAZ Studio Pro BETA product to your account, simply locate it within your Itemized Order History and then click the "Reset" link on its immediate right. This will cause new links for downloading the latest version to be added to your My Downloadable Products list.

If this is your first time downloading DAZ Studio Pro BETA, simply follow this link, click the "add to cart" button on the page and then follow the checkout process.

Is there any documentation?

Yes, some documentation is located here.

Post edited by DAZ_Brian on
«134

Comments

  • lexus2000lexus2000 Posts: 1
    edited December 1969

    Beta not showing up in MY Card and not in my "Itemized Order History" either

    I am not too unhappy; since Your compatiblity trick DS is steady as a rock

    Lex

  • stumpcstumpc Posts: 0
    edited December 1969

    I'm getting an install error in the 64 bit install when it tries to uninstall the previous version, here is an image of to dialog warning:
    I'm on Windows Vista x64
    AMD+5200 athlon II
    8 gigs of ram

    Daz_64_bit_Install_warning.JPG
    696 x 408 - 59K
  • BejaymacBejaymac Posts: 1,024
    edited December 1969

    Uninstall the old version before you try to install the new version.

  • stumpcstumpc Posts: 0
    edited December 1969

    Bejaymac said:
    Uninstall the old version before you try to install the new version.

    Unfortunately there is no trace of my prior uninstall left after running this installer, It seems it has removed something critical as it no longer shows in the DAZ start menu folder or in the control panel.

    Good news is DAZ Studio 4.5.6 64 is still intact so no problem there, hopefully I'm the only one that is having this problem and if that is the case I'll wait until the release candidate is available.

  • mjc1016mjc1016 Posts: 7,237
    edited December 1969

    Can't get the beta to run under any version of Wine...nor any 'bit' format.

    Both the 32 and 64 bit versions will load and start, but the moment any content is added it crashes.

    Unhandled exception error in kernel32.dll...

    This occurs somewhere around the 99-100% mark in the 'reading asset' box.

    Really wanting the 3Delight update, but oh well.

  • Kendall SearsKendall Sears Posts: 1,882
    edited December 1969

    mjc1016 said:
    Can't get the beta to run under any version of Wine...nor any 'bit' format.

    Both the 32 and 64 bit versions will load and start, but the moment any content is added it crashes.

    Unhandled exception error in kernel32.dll...

    This occurs somewhere around the 99-100% mark in the 'reading asset' box.

    Really wanting the 3Delight update, but oh well.

    Yup. Newest DS4 is a complete failure under Wine. I'm getting an OpenGL failure under Wine 1.5.3 -> 1.5.16.

    From 100% working to startup failure.

    Kendall

  • Kendall SearsKendall Sears Posts: 1,882
    edited December 1969

    Wine Success! Partial anyway. More information as I have it. I have managed to get 4.5.1.41 up and Genesis loaded.

    Kendall

  • Kendall SearsKendall Sears Posts: 1,882
    edited November 2012

    Wine Success! Partial anyway. More information as I have it. I have managed to get 4.5.1.41 up and Genesis loaded.

    Kendall

    Well, that was short lived. Back to crashing at trying to start viewport.

    X Error of failed request: BadMatch (invalid parameter attributes)
    Major opcode of failed request: 72 (X_PutImage)
    Serial number of failed request: 4267
    Current serial number in output stream: 4283

    .41 is a total loss for Wine users.

    bug report here but since Wine is not a supported platform I don't think it'll be recognized.

    Kendall

    Post edited by Kendall Sears on
  • Kendall SearsKendall Sears Posts: 1,882
    edited December 1969

    Interesting set of data points...

    I had a "new" Fedora17 install that had nothing Wine or DAZ related installed on it. So, I decided to use it to get some detailed trace information to submit to the bug tracker. I install Wine 1.5.16(64 bit) from the yum repository. Then I install the DS4.5.1.41 (64 bit), from now on referred to as "DS4". The installer complains and hacks and coughs, but finally finishes. I start DS4 running a fairly detailed trace. The screen on this machine is a 16x9 1366x768 LCD and is slight too short for the DS4 startup dialogs to fit on (HINT DAZ!!!) and I have to blindly flail around using the TAB and ENTER keys until I work my way past them (making sure to select "Don't show this again"). Finally, I have DS4 on screen showing an empty Viewport. I exit, and DS4 crashes. No problem, I was done.

    I install the Genesis essentials and it installs without complaint. I then restart DS4 and run into a multi-thread deadlock where the "default load screen" is trying to load Genesis, and the Metadata load dialog is trying to install the Metadata... AT THE SAME TIME! So... on a 2.1Ghz DualCore machine we're now waiting... and waiting.... and waiting... I have nothing else to do on the machine so I set it aside and do other things. Eventually, it works its way through the situation and I'm looking at a viewport with Genesis. Smart Content is behaving, things are turning Orange as I mouse over them, there is the normal ATI OpenGL lag on input. I exit DS4 (no save), and get the crash dialog.

    I restart DS4 and load the RtR Dragon Slayer scene. It loads, but doesn't display until I mouse over the viewport. ATI lag... again. Anyway, things seem OK, change the theme to City Limits. Change occurs, set the tool to bounding box only, still OK. Exit DS4.... no crash this time.

    Restart DS4, relatively speedy startup. Set the layout to Highway, then 3D Bridge, then Full Service, then back to Highway. Everything changes as expected, exit DS4, no crash.

    Restart DS4, no crash. Close DS4, no crash.

    Been drafted to brave the crowds by the female contingent. Will continue later... if I survive.

    Kendall

  • RAMWolffRAMWolff Posts: 5,298
    edited December 1969

    Installed and checked things out last night. All works fine. I'm going to try the GoZ Bridge and see if it's back to working a bit faster. This past couple of versions it takes a bit of time to invoke... might be a ZBrush thing.. who knows these days! Thanks for the beta.

  • mjc1016mjc1016 Posts: 7,237
    edited November 2012

    Kendall...

    Possibly related to my problems with trying to get the beta to run.

    I looked at the log file and for some reason, it's reporting an OpenGL version of 2.1.x when before I tried the beta, DS always had the right version...OpenGL 4.2. But right now the system is reporting the correct OpenGL, WINE/DS is not...

    Post edited by mjc1016 on
  • 1drworx1drworx Posts: 10
    edited December 1969

    Anybody having install problems with Windows 8? I tried the regular way but keep getting error messages with main installer and content and plugins.
    Tried a complete uninstall of version 4.5.1.6 and tried installing new beta but still getting error messages. This the first time I have had problems installing any version.

  • Jay_NOLAJay_NOLA Posts: 0
    edited December 1969

    What are the file sizes for the files in the Beta? I've been having trouble getting everything to download and want to make sure the files didn't have any problems.

  • BejaymacBejaymac Posts: 1,024
    edited December 1969

    I can't tell you all of the sizes, just the two I've downloaded.

    DAZStudio_4.5.1.41_Win64_Bundle.zip - 165 MB
    14812_GenesisStarterEssentials_1.9_trx.exe - 429 MB

  • mjc1016mjc1016 Posts: 7,237
    edited December 1969

    Bejaymac said:
    I can't tell you all of the sizes, just the two I've downloaded.

    DAZStudio_4.5.1.41_Win64_Bundle.zip - 165 MB
    14812_GenesisStarterEssentials_1.9_trx.exe - 429 MB

    And 164 MB for the 32 bit version.

  • Kendall SearsKendall Sears Posts: 1,882
    edited December 1969

    mjc1016 said:
    Kendall...

    Possibly related to my problems with trying to get the beta to run.

    I looked at the log file and for some reason, it's reporting an OpenGL version of 2.1.x when before I tried the beta, DS always had the right version...OpenGL 4.2. But right now the system is reporting the correct OpenGL, WINE/DS is not...

    D|S is doing a fairly extensive query of the OpenGL layer upon startup. Are you using a proprietary video driver? If so, there may be a missing routine or two that is getting flagged with this version.

    Kendall

  • mjc1016mjc1016 Posts: 7,237
    edited December 1969

    Yeah...I'm using Nvidia's drivers.

    It took reinstalling the driver and reinstalling WINE to get it back. Using winedebug made it easy to spot...the crash dumps from the crashes, much less than worthless (Unknown error in Kernel32.dll...and so on).

    The difference is amazing. The number of extensions not initialized on OpenGL2.1 is rather alarming and to me explains why some people could be having such trouble 4.5 to run. Before I got it fixed, it was acting a lot like many people describe DS acting...the constant crashing when doing anything, the not loading at all and if it does, absolutely crappy viewport behavior.

    Just a rough guess on my part, but I'd say a completely working OpenGL of around 3.0 is really the 'practical' minimum for DS4.5.

  • Kendall SearsKendall Sears Posts: 1,882
    edited November 2012

    mjc1016 said:
    Yeah...I'm using Nvidia's drivers.

    It took reinstalling the driver and reinstalling WINE to get it back. Using winedebug made it easy to spot...the crash dumps from the crashes, much less than worthless (Unknown error in Kernel32.dll...and so on).

    The difference is amazing. The number of extensions not initialized on OpenGL2.1 is rather alarming and to me explains why some people could be having such trouble 4.5 to run. Before I got it fixed, it was acting a lot like many people describe DS acting...the constant crashing when doing anything, the not loading at all and if it does, absolutely crappy viewport behavior.

    Just a rough guess on my part, but I'd say a completely working OpenGL of around 3.0 is really the 'practical' minimum for DS4.5.

    I wouldn't go that far. There are some features that will probably be leveraged if they are available, but I doubt seriously that OpenGL >1.4 or 1.5 is necessary to actually use D|S4.5. I'd have to run a lowlevel trace to know for certain, and I'm too busy helping a friend on a coding project right now to take that kind of time.

    Kendall

    Post edited by Kendall Sears on
  • barbultbarbult Posts: 3,407
    edited December 1969

    I saw this in the change log:
    "Change default mapped directory to be ”/My DAZ 3D Library” instead of “DAZ 3D/My DAZ Library”
    I don't understand what this means. Do I have to change something in my folder structure, or is this all internal and invisible to the user?

  • Richard HaseltineRichard Haseltine Posts: 19,379
    edited December 1969

    barbult said:
    I saw this in the change log:
    "Change default mapped directory to be ”/My DAZ 3D Library” instead of “DAZ 3D/My DAZ Library”
    I don't understand what this means. Do I have to change something in my folder structure, or is this all internal and invisible to the user?

    No, it means for some reason they have changed the default that is placed in the entry field when installing if there isn't a previous value. The name of the folder is not functionally significant so you can continue to call the folder whatever you like - you shouldn't even notice that the default has changed unless you install on a clean system without a stored previous setting.

  • ManStanManStan Posts: 0
    edited November 2012

    Why can't I orient tabs across the top? I select it and the tabs just vanish.
    Never mind, close it opened it and there are the tabs.

    Yes I just got this downloaded and installed today. Next question.

    Does dynamic clothing not work in this? Nothing loads, yes I installed the dynamic clothing control even though I can't use it.

    I'll assume since there is no dynamic clothing tab it doesn't.

    edit to add, checking "do not show this again" doesn't work. It still shows the intro tutorial/walk through page every time.
    .

    Post edited by ManStan on
  • wallace3dwallace3d Posts: 68
    edited November 2012

    anyone with Windows 8 know how to unlock the read only status of the daz studio 4 folder? its preventing the install as its a read only folder and no matter what I have done I cannot make it an all access open folder. I unselect read only.. it applies the changes ( or appears to) but when I go back into it the folder is still read only.

    EDIT: Never Mind its not set to read only. Just for some reason Windows 8 is not letting the installer replace the file

    Post edited by wallace3d on
  • wallace3dwallace3d Posts: 68
    edited November 2012

    I am getting this error message. and I am not sure that the prev version was uninstalled correctly.

    daz4beta_install_error.jpg
    516 x 163 - 78K
    Post edited by wallace3d on
  • Kevin-McKeeKevin-McKee Posts: 645
    edited November 2012

    Still getting the "duplicate IDs" error each time I load the base Genesis figure (14812_GenesisStarterEssentials_1.9_trx.exe) in DAZ Studio Pro BETA (4.5.1.41) (64-bit on Windows 7), and then DAZ Studio crashes to the desktop. (Exception Reason: DAZStudio.exe caused ACCESS_VIOLATION in module "C:\Windows\system32\ig4icd64.dll" at 0033:0000000008581120)

    BTW: The 14812_GenesisStarterEssentials_1.9_trx.exe appears to work fine with DAZ Studio Pro BETA (4.5.0.137) (64-bit on Windows 7).

    Post edited by Kevin-McKee on
  • mjc1016mjc1016 Posts: 7,237
    edited December 1969

    wallace3d said:
    I am getting this error message. and I am not sure that the prev version was uninstalled correctly.

    This coupled with your previous post sounds more like a Windows problem than a DS one...namely permissions/account restrictions.

    I'd say either you are having your AV software kick in and mess with install or Windows file protection is kicking in and stopping the install.

  • mjc1016mjc1016 Posts: 7,237
    edited December 1969

    ManStan said:
    Why can't I orient tabs across the top? I select it and the tabs just vanish.
    Never mind, close it opened it and there are the tabs.

    Yes I just got this downloaded and installed today. Next question.

    Does dynamic clothing not work in this? Nothing loads, yes I installed the dynamic clothing control even though I can't use it.

    I'll assume since there is no dynamic clothing tab it doesn't.

    edit to add, checking "do not show this again" doesn't work. It still shows the intro tutorial/walk through page every time.
    .

    If you right click in the area where the panes (tabs) are, does the DCC show on the list of ones to add, when you select Add Pane? (Also accessible from Window > Panes > drop down list.)

    As for the other...when you check the "Don't show this..." box, there should be two buttons to the right (bottom right hand side of the window). One will close the window without saving the choice (I think that's Cancel) and the other will save the choice (I believe it is grayed out until you check the 'Don't show' box).

  • wallace3dwallace3d Posts: 68
    edited December 1969

    mjc1016 said:
    wallace3d said:
    I am getting this error message. and I am not sure that the prev version was uninstalled correctly.

    This coupled with your previous post sounds more like a Windows problem than a DS one...namely permissions/account restrictions.

    I'd say either you are having your AV software kick in and mess with install or Windows file protection is kicking in and stopping the install.

    when I had windows 8 the 4.5.1.6 installed just fine

    I notices that all the files that had the modification date of 10/8/2012 from that install were the ones that were not properly uninstalled. I got it to work..
    probably not the best practice and may cause Issues but I manually deleted all the files that had the modification date of 10/8/2012.

  • wallace3dwallace3d Posts: 68
    edited December 1969

    OMG I am such a Doofus. The reason that the uninstall did not un install correctly was because I had a session open UUUGHH!! *Bangs Head on Desk*

  • mjc1016mjc1016 Posts: 7,237
    edited December 1969

    mjc1016 said:
    Yeah...I'm using Nvidia's drivers.

    It took reinstalling the driver and reinstalling WINE to get it back. Using winedebug made it easy to spot...the crash dumps from the crashes, much less than worthless (Unknown error in Kernel32.dll...and so on).

    The difference is amazing. The number of extensions not initialized on OpenGL2.1 is rather alarming and to me explains why some people could be having such trouble 4.5 to run. Before I got it fixed, it was acting a lot like many people describe DS acting...the constant crashing when doing anything, the not loading at all and if it does, absolutely crappy viewport behavior.

    Just a rough guess on my part, but I'd say a completely working OpenGL of around 3.0 is really the 'practical' minimum for DS4.5.

    I wouldn't go that far. There are some features that will probably be leveraged if they are available, but I doubt seriously that OpenGL >1.4 or 1.5 is necessary to actually use D|S4.5. I'd have to run a lowlevel trace to know for certain, and I'm too busy helping a friend on a coding project right now to take that kind of time.

    Kendall

    Ok, maybe not quite 3...

    But from what I've noticed of what was not initialized, there were a lot that seem to be very common, now. Without knowing exactly which extensions are required and which are 'just in case' it's hard to say, but from the way the UI was acting, something is missing from 2.1 that is needed. (The crashes were definitely UI/viewport related),

  • mjc1016mjc1016 Posts: 7,237
    edited December 1969

    wallace3d said:
    OMG I am such a Doofus. The reason that the uninstall did not un install correctly was because I had a session open UUUGHH!! *Bangs Head on Desk*

    I think anyone who had installed more than one updated software package had done that one...

Sign In or Register to comment.
Rocket Fuel