Congratulations! You are a March Madness BONUS BUYER!

Enjoy 10% OFF* ALL PURCHASES STOREWIDE or enjoy 30% OFF items with a SKU number lower than 16000 & 30% OFF items from Runtime DNA.

Offer valid for intended recipient only
* 10% discount DOES apply to Gift Cards and Memberships. **Items must be in cart simultaneously for discount to apply.
[ collapse ]

DSON Poser loads Figure, No Actor

slojoslojo Posts: 0
edited December 1969 in Daz Studio Discussion


I'm on a MacPro at 10.6.6, and use the 64bit versions of Poser and DazStudio 4.5. I've reinstalled DS-4.5 several times as well as the Poser 3.1 update release.

I have been a Poser user since forever (version 1), and have used Zygote (DAZ) items for almost as long. When they came out with DazStudio, I tried it and didn't care for it and pretty much thought it was unintuitive, but I've always followed its development, because I like the DAZ folks. I figured they would get it up to speed eventually. It's been about 7 years now and, finally, DazStudio at version 4.5 looks good. I like the user interface, it's less unintuitive and it seems to have a fair amount of functionality - AND there's the Genesis product to go with it. Very nice. I like mixing up the characters. It's an ingenious approach. Genesis works great in Studio… but I'm not having much success with Genesis in Poser.

Everything installs well. I can see the Runtime in Poser, I can see the Base figures and Genesis, and all the standard stuff it loads with, as well as V5 and M5. Looks like any other library directory. But when I try to load them (any of them), I get a "Figure 1" with No Actor. What I do get (but not always) is "GoalCenterOfMass" and that's it. No visibility of Genesis DSON product except on the Libraries pane. They do not load into the scene, though I can see them in the Library, and they say they are loading. The visibility tags in the Properties tab are not enabled (when selected, they immediately unselect), and when trying to select the the Actor/GoalCenterOfMass it crashes Poser 2012 immediately. My Poser 2012 installation has never - I repeat, never - crashed. Until now.

I have installed and uninstalled the Companion files both into volume/user/Documents/Daz3D/Studio/My Library and then into a Genesis content folder in Poser 2012. Same result. It doesn't seem to matter where the two Genesis Starter Essentials files are located, nothing but "GoalCenterOfMass' loads into the Poser scene. It almost seems as if the normals are reversed. But then, if that were the case, I should still see the actor loading. I believe Netherworks had a similar problem. I have also installed and uninstalled DSON several times. None of this really makes any sense. It should load. SO… I created a Base figure in DAZStudio (Genesis with Base Male applied) and exported to Poser to try and see if that would load. It took 4 hours to load a single figure with no hair, no clothing, no shoes, nada, zilch, nyet! Are you kidding me? Four hours? (THAT is a major problem, DAZ!).

Anyway, it gets to Poser okay. And when double-clicked to load, it attempts to load, but then an error emerges:
--> Could not find file: /Runtime/Geometries/DAZ3D/Genesis/Base/Genesis_05025a83_95dc_980b_e41a_21c335c09f40.obj <--</p>

I have no idea if one has anything to do with the other, but Netherworks had mentioned in another thread that he came across a long string for an obj moniker, so perhaps it does. I don't know. As a separate object file, it does not exist on the computer, which tells me that it may be an internal string embedded in code somewhere, perhaps in Genesis. Or not, I don't know.

If anyone knows how to repair/work around this, I'd be be pleased to hear. I'm sure that Digital Art Zone and Smith-Micro will play nice with one another and sort this out eventually, but I hope they do it sooner than later, because I won't be purchasing any more DSON product (or anything else) in the meanwhile… or upgrading to the next paid Poser version, or the next paid DSPro version. Just out of spite! ;-)


  • Richard HaseltineRichard Haseltine Posts: 32,553
    edited December 1969

    Where is /Runtime/Geometries/DAZ3D/Genesis/Base/Genesis_05025a83_95dc_980b_e41a_21c335c09f40.obj on your system, assuming it exists at all? Do you have /Data/DAZ 3D/Genesis/Base/Genesis.dsf sitting inone of the folders you have added to Poser as an external library (not in a subfolder)?

  • slojoslojo Posts: 0
    edited November 2012

    Where is /Runtime/Geometries/DAZ3D/Genesis/Base/Genesis_05025a83_95dc_980b_e41a_21c335c09f40.obj on your system, assuming it exists at all? Do you have /Data/DAZ 3D/Genesis/Base/Genesis.dsf sitting inone of the folders you have added to Poser as an external library (not in a subfolder)?

    As I mentioned: "As a separate object file, it does not exist on the computer...."

    Yes, the dsf file exists in "Documents/Daz3D/Studio/My Library/data/DAZ 3D/Genesis/Base/Genesis.dsf" and My Library exists as a directory in the Library pane of Poser.

    [edited to correct Genesis/dsf to Genesis-dot-dsf]

    Post edited by slojo on
  • Richard HaseltineRichard Haseltine Posts: 32,553
    edited December 1969

    I'm not familiar with Macs, but does Poser have write acces to the My Library folder or only read? If you can tell, how about the DSON importer?

  • slojoslojo Posts: 0
    edited December 1969

    I would assume so. I'm the only user of this machine and have always had admin access. Would you know of a way to check for sure?

  • slojoslojo Posts: 0
    edited December 1969

    Get Info screen informs me that I have Read & Write access to My Library. I don't know how I would go about checking DSON. Isn't that just a script?

  • slojoslojo Posts: 0
    edited December 1969

    Problem solved - this is my small journal of what I did.

    Sun., Nov 23: loaded and reloaded DSON several more times. Not exactly sure why, but I finally got a figure with actor to load. I can now see the materials of the figure in Poser's Material tab, as with any other figure. The problem is that the figure itself is still not visible in the Pose tab, although Visible is active in the Properties tab.

    Mon., Nov. 24: tried turning Show Progress On Load (DSON Importer Preferences) on and off, with invisible figure loaded and without it loaded, and with adding a standard V4 figure that was visible in the scene as well. I did this about a couple of dozen times. Each time I would quit the application normally and then restart the app. No change. Anyway, V4 figure is visible, Genesis figure is not, though it's materials are visible in the Materials tab. Show Progress On Load was set back to off, which I think, is currently recommended by the user community.

    Sat., Nov. 29: Okay, it has to be some kind of permissions issue. Richard Haseltine mentioned that it could be a read/write issue. So, I'll have a look at that this weekend. [Later] The Genesis figure is loaded, and doesn't crash. Materials are visible and selected and can be changed without crashing anything. The figure is still invisible. So it must be permissions of some sort.

    Dec. 1: Began setting the permissions for each individual folder in Poser to Read & Write…. [Later] Well, that took a while. The DSON process seems to work. Genesis loads, clothing loads, materials load, textures load. Shapes can be manipulated. It looks fine and there are no crashes. Haven't had much time to try it out a whole lot, but it looks okay.

    (OR… one could just pay attention and do it the correct way, following):

    Dec. 1 (Late): Ah, DSON. So, now I know what the problem has been. If I had any bit of real intelligence, I'd be dangerous.

    The GenesisStarterEssentials and GenesisStarterEssentialsPoserCF should be installed into a specific folder on the Mac, which is located at Users/Shared/Poser Pro 2012 Content. Poser Pro 2012 creates this folder. Who knew? Not me. But as DSON has worked for other Mac users, I suppose they knew. Mac users who have always created their runtimes as external to Poser under Applications would also have no problem. I've checked and both of these scenarios work correctly.

    I had no idea Poser was creating a content folder in Users/Shared. I must have missed that in the documentation, because when I installed Poser 2012 some months ago all content was automatically loaded into the Poser 2012 app folder as it had always been done before. That's where I have always left it. And while it's also true that resetting all folders to Read & Write in the main Poser folder will work, as I can now verify, that just borders on craziness.

    I read the above information (Dec. 1) in another post, where Richard Haseltine informed poster Tazz1 to place Starter Essentials and CF files in Users/Shared/Poser Pro 2012 Content. The DSON documentation are written for Windows, and no mention is made of a Poser Pro 2012 Content folder created by Poser. It does, however, mention external runtimes. so Mac users might start with placing DSON product into the Poser Pro 2012 Content folder if they are having difficulties. Again, it also works (as Haseltine pointed out) if content is placed in any external runtime (external to the folder where the Poser app is located), which is absolutely the case. As he stated, it needs to have write capability.

    And now it works for me without a hitch. And DSON is pretty spiffy. But I'm also beginning to like DS 4.5.

    And, oh yeah, I kept on buying Daz3D product anyway… I mean, who could pass up all those deals, spite or no spite?

    ALSO… in another thread, I lambasted posters for what I thought were rude and inconsiderate responses to an OP's frustration. I dislike incivility. Unfortunately, in responding to what I felt was incivility, I was rude and uncivil myself in my reply. I should know better. Mea culpa. That thread was closed before I got back to it. So, should any of those good people happen upon this thread in the future, I sincerely apologize for my own rudeness. Unequivocally.

  • Richard HaseltineRichard Haseltine Posts: 32,553
    edited December 1969

    Thanks for getting back to this thread - I'll try pointing out that the Mac folder setup needs a separate note from the Windows setup.

  • slojoslojo Posts: 0
    edited December 1969

    Mr. H., that would be great. Of course, I should have understood the reason for write permissions as well as external runtimes as most folks have moved to them long ago. The digital lightbulbs don't seem as bright (or as frequent) these days. ;-)

Sign In or Register to comment.