Half of my hair is missing.

hakatrehakatre Posts: 0
edited December 1969 in New Users

I thought it was just the standard hair that came with Genesis but, it happens to the hair files I purchased also. When I load the hair to either Genesis or V4, half of the top is transparent. This is very annoying. No problem with conforming, it's just missing at the top. Can someone please tell me how to get around this? Any help is appreciated.

Comments

  • KickAir 8PKickAir 8P Posts: 1,843
    edited November 2012

    hakatre said:
    I thought it was just the standard hair that came with Genesis but, it happens to the hair files I purchased also. When I load the hair to either Genesis or V4, half of the top is transparent. This is very annoying. No problem with conforming, it's just missing at the top. Can someone please tell me how to get around this? Any help is appreciated.

    Is it transparent in the render, or just in the viewport? If in the viewport (in DAZStudio, not sure this happens in Poser, and you didn't say what software you're using) that's a common glitch that can happen to overlapping transparency maps (like in most hair), but it should render fine. If it's in the render then I don't know, sorry.

    Post edited by KickAir 8P on
  • SzarkSzark Posts: 8,796
    edited December 1969

    What Product/s?
    It is fitting correctly?
    Does it have a "Fit To" command in the Parameters Pane?
    What Version, exactly, of Daz Studio are you using?

  • hakatrehakatre Posts: 0
    edited November 2012

    Thanks KickAir 8P, Szark. I am using Daz Studio 4.5 using Genesis and V4 in the view port only (before any rendering). I can't be the only one who is experiencing this. Most of the crown of the hair is like the opacity is 25% and you can see straight through to the scalp. The rest of the (flowing) hair is ok. Very frustrating. I need to be able to fix this. Can't have a half head of hair. :(

    Post edited by hakatre on
  • JimmyC_2009JimmyC_2009 Posts: 8,356
    edited December 1969

    If you were to name the hair items that dont work for you, we may be able to help.

  • KickAir 8PKickAir 8P Posts: 1,843
    edited November 2012

    hakatre said:
    Thanks KickAir 8P. I am using Daz Studio 4.5 in the view port only (before any rendering). I can't be the only one who is experiencing this. Most of the crown of the hair is like the opacity is 25% and you can see straight through to the scalp. The rest of the (flowing) hair is ok. Very frustrating. I need to be able to fix this. Can't have a half head of hair. :(

    That sounds like you haven't tried a test render yet -- if you haven't, then do one. Is the problem happening in the render? If not, you're just gonna have to put up with it looking weird in the viewport, because (IIRC) it's something DAZStudio gets from OpenGL and DAZ can't fix it.

    If it's happening in the render also then look at Szark's post: is the hair's "Fit To" parameter set to your figure? Is the hair intended for your figure? In this case that's Genesis, which means that if you're using V4 or M4 (or any previous generations') hair it needs to be converted -- even if you're using Genesis hair, a lot of them come with fits for Mil4 figures, and it can be easy to use one of those accidentally.

    If it's none of those then I'm out of ideas, sorry. Go to the "Help" menu option, click on "About DAZ Studio", note down the entire version number, and post it here -- somebody else may be able to help. Oh, and JimmyC_2009's right, tell us what some of the hairs are that you've tried and had this problem with, even if the answer's "all of them".

    Post edited by KickAir 8P on
  • AkhbourAkhbour Posts: 0
    edited December 1969

    hakatre said:

    Half of my hair is missing

    You are lucky!

    All of my hair is missing!

    Could be a question of age ...

  • hakatrehakatre Posts: 0
    edited December 1969

    I'll have to do a test render and see what happens. Hoping it's just a pre-render glitch. I'm new at this so, haven't rendered anything yet. No issues with auto fit when loading the hair, perfect there and made sure to match the hair with the compatible character. I'm at work now so may not get the names of the hair correct - Fervera hair and the Romana hair.

  • SzarkSzark Posts: 8,796
    edited December 1969

    Akhbour said:
    hakatre said:

    Half of my hair is missing

    You are lucky!

    All of my hair is missing!

    Could be a question of age ...

    ROFLOL Baldy. You want some of mine, I have loads of really long hair.

  • AkhbourAkhbour Posts: 0
    edited December 1969

    When you get home, do a test render just to see.

    As Kickair said, the preview can play tricks like that, especially when you have another transmapped prop like a window or the hair of another character right behind.

  • hakatrehakatre Posts: 0
    edited November 2012

    Version: Daz Studio 4.5, Genesis Essentials
    Characters: Genesis, V4, V4.2 base & Morphs++

    Post edited by hakatre on
  • Richard HaseltineRichard Haseltine Posts: 19,960
    edited December 1969

    Duplicate thread merged and merged thread moved to New Users Help and Discussions. If you think a thread is in the wrong place please ask the mods to move it, don't simply start a new thread which will lead to people wasting their time covering ground already covered in the previous thread.

    As has been said, you need to render to see if there's an issue you need help with or if it's just the limitation of the DS preview.

  • hakatrehakatre Posts: 0
    edited December 1969

    Thank you, Richard. Please accept my apology, I'm just new to all this and trying to learn. Thanks for putting the thread in the right place. I will try to render a scene and see what happens.

  • Richard HaseltineRichard Haseltine Posts: 19,960
    edited December 1969

    hakatre said:
    Thanks for putting the thread in the right place.

    Except I hadn't, I'd put it in the New Users Contests forum instead - fixed that now.

  • hakatrehakatre Posts: 0
    edited December 1969

    Well, did my first render and that did the trick (sigh of relief). One less growing pain for this newbie.
    But, still a little taken back by the fact that the hair is partially missing while setting the models up. I
    figure there might be a way around that but I guess I could live with it. So, if anyone knows how to
    get around that, please let me know.

  • AkhbourAkhbour Posts: 0
    edited December 1969

    The only way around that is opening the hair materials in the surface tab and deleting all trans maps while posing, setting up the scene and to re-apply just before rendering.

    But I don't see any reason for that, I can hardly imagine a situation where this OpenGL issue might cause a problem.

    You may check if there is a newer version of your graphic card driver, but as far as I can remember (which goes back to DS 0.8 I think (Does anyone know when that was?)) it has always been that way, be it with an ATI or Nvidia card.

    And you may find even more strange looking hairs when you place two "hairy" characters one behind the other! ^_-

  • IceScribeIceScribe Posts: 0
    edited November 2012

    The Purple Bikini the fix has been there all along. I forget what arcane web tut I found this but the bikini can be ignored!

    When using the v4 power loader (DAZ3) a dialog window comes up with Basic and Advanced Tabs
    Click Advanced Tabs
    inside that is another set of tabs
    Click Presets
    notice ittybitty checkbox in upper left corner-click it where it says Load Presets
    There should be three choices with circles in front
    Mapless
    All Natural with Bikini (the default)
    All Natural No Gens
    I click the 3rd and Accept
    You will see the Loader loading up V4 morphs + etc and to your dismay you will see behind the status window that purple bikini
    Fear Not! After all the loading is done
    Voila She Appears Sans Bikini!

    Sorry I don't know how to do the screen capture for this.

    I've noticed sometimes I can see through the eyeballs too. I think one can select a different a "different drawstyle for the selected port" with one of the big round buttons near the View selector box. One of those styles may be more familiar for you while working in with the model before rendering.

    Post edited by IceScribe on
  • hakatrehakatre Posts: 0
    edited December 1969

    Thanks Akhbour, but I'm not going to go through all of that. The hair looks great after rendering so, I can't complain. Just hard to adjust / morph the hair BEFORE rendering since it is invisible on the top, sides and back of the crown. So, I'll live with it until someone can tell me how to see all the hair in the view port prior to rendering.

  • mjc1016mjc1016 Posts: 7,899
    edited December 1969

    hakatre said:
    Thanks Akhbour, but I'm not going to go through all of that. The hair looks great after rendering so, I can't complain. Just hard to adjust / morph the hair BEFORE rendering since it is invisible on the top, sides and back of the crown. So, I'll live with it until someone can tell me how to see all the hair in the view port prior to rendering.

    Temporarily remove the transparency maps...go to each surface and swap them with the corresponding diffusion map.

    Pose/shape...then switch them back.

    You can even switch them all out, then save a materials preset for the switched hair, then reload the 'original' material before rendering b That way you won't have to switch them every time you use that hair.

  • hakatrehakatre Posts: 0
    edited December 1969

    Ok, that's great uh, now how does one remove the transparency maps? I brand new to this stuff.

  • mjc1016mjc1016 Posts: 7,899
    edited November 2012

    hakatre said:
    Ok, that's great uh, now how does one remove the transparency maps? I brand new to this stuff.

    In the Surface pane look for Opacity, then set the map to None.

    screen24.png
    1280 x 1024 - 516K
    Post edited by mjc1016 on
  • hakatrehakatre Posts: 0
    edited December 1969

    Ok, I see now that you meant "opacity strength." I'm familiar with the surface settings. Didn't solve the issue with the invisible hair. But, I'm happy for the moment.

Sign In or Register to comment.
Rocket Fuel