I have DS 4.5.1.6 but still can't use Uber Area Lights

luci45luci45 Posts: 1,154
edited December 1969 in DAZ Studio Discussion

DS crashes when I try to render a scene with Uber Area Lights. I reported this as a bug and was told that it works OK and I should try installing the Genesis Starter Essentials 1.6 in case there was still an old version of Uber Area Lights in my content. Doing this didn't work and I don't know what else to try. The UberAreaLight Base is a .dsa file from 2012. Seems weird to me that it's not a later file and a .duf.

Comments

  • Richard HaseltineRichard Haseltine Posts: 19,413
    edited December 1969

    My preset is a .dsa from February, so that doesn't sound wrong - of course that's only a preset, not the shader itself which is in C:\Program Files\DAZ 3D\DAZStudio4\shaders\DAZ\Uber\surface

  • luci45luci45 Posts: 1,154
    edited December 1969

    My preset is a .dsa from February, so that doesn't sound wrong - of course that's only a preset, not the shader itself which is in C:\Program Files\DAZ 3D\DAZStudio4\shaders\DAZ\Uber\surface

    OK, thanks for that. How do I fix this so I can use Uber Area Lights? Do I submit a ticket with tech support or go to another forum?

  • Richard HaseltineRichard Haseltine Posts: 19,413
    edited December 1969

    I would try reinstalling both DS and the Starter Essentials. If that doesn't fix it, try rendering and then when DS crashes go to the log file (C:\Users\You\AppData\Roaming\DAZ 3D\Studio 4\log.txt) and see what the last few messages are.

  • barbultbarbult Posts: 3,411
    edited December 1969

    Luci45, do you have progressive rendering checked by any chance. That crashes Uber Area lights for me.

  • luci45luci45 Posts: 1,154
    edited December 1969

    barbult said:
    Luci45, do you have progressive rendering checked by any chance. That crashes Uber Area lights for me.

    Wow! Thanks Barbult, that worked. I did have progressive rendering on. When I turned it off, no more crashing. :cheese:

    Thank you, also Richard. I'd rather not reinstall as this same thing happened with 4.5.0.137.

  • barbultbarbult Posts: 3,411
    edited December 1969

    Luci45 said:
    barbult said:
    Luci45, do you have progressive rendering checked by any chance. That crashes Uber Area lights for me.

    Wow! Thanks Barbult, that worked. I did have progressive rendering on. When I turned it off, no more crashing. :cheese:

    Thank you, also Richard. I'd rather not reinstall as this same thing happened with 4.5.0.137.


    I'm glad that worked for you! I'm going to go file a bug report right now. When I discovered the problem, I didn't have a Mantis account. I do now.

  • luci45luci45 Posts: 1,154
    edited December 1969

    barbult said:
    Luci45 said:
    barbult said:
    Luci45, do you have progressive rendering checked by any chance. That crashes Uber Area lights for me.

    Wow! Thanks Barbult, that worked. I did have progressive rendering on. When I turned it off, no more crashing. :cheese:

    Thank you, also Richard. I'd rather not reinstall as this same thing happened with 4.5.0.137.


    I'm glad that worked for you! I'm going to go file a bug report right now. When I discovered the problem, I didn't have a Mantis account. I do now.

    Yes, I remember you couldn't access it. I am also going to report this - they have been ignoring me since Thursday. Maybe if two people tell them the same thing they will be more interested.

  • barbultbarbult Posts: 3,411
    edited November 2012

    Luci45 said:
    barbult said:
    Luci45 said:
    barbult said:
    Luci45, do you have progressive rendering checked by any chance. That crashes Uber Area lights for me.

    Wow! Thanks Barbult, that worked. I did have progressive rendering on. When I turned it off, no more crashing. :cheese:

    Thank you, also Richard. I'd rather not reinstall as this same thing happened with 4.5.0.137.


    I'm glad that worked for you! I'm going to go file a bug report right now. When I discovered the problem, I didn't have a Mantis account. I do now.

    Yes, I remember you couldn't access it. I am also going to report this - they have been ignoring me since Thursday. Maybe if two people tell them the same thing they will be more interested.


    Well, reporting it didn't do us much good , did it!

    Post edited by barbult on
  • luci45luci45 Posts: 1,154
    edited December 1969

    barbult said:
    Luci45 said:
    barbult said:
    Luci45 said:
    barbult said:
    Luci45, do you have progressive rendering checked by any chance. That crashes Uber Area lights for me.

    Wow! Thanks Barbult, that worked. I did have progressive rendering on. When I turned it off, no more crashing. :cheese:

    Thank you, also Richard. I'd rather not reinstall as this same thing happened with 4.5.0.137.


    I'm glad that worked for you! I'm going to go file a bug report right now. When I discovered the problem, I didn't have a Mantis account. I do now.

    Yes, I remember you couldn't access it. I am also going to report this - they have been ignoring me since Thursday. Maybe if two people tell them the same thing they will be more interested.


    Well, reporting it didn't do us much good , did it!

    I just got a reply from Mantis Bug Tracker:

    "OK, that makes much more sense. Progressive rendering causes serious memory spikes and crashes when you push it past the limits of your machine."

    Sounds OK, I don't really need Progressive rendering and had no idea it "causes serious memory spikes."

    Thanks again for your help. I probably never would have figured that out and DAZ never mentioned it as far as I know.

  • bluemoonbluemoon Posts: 0
    edited December 1969

    Thank you all so much for this thread, I was having the same problem with the area lights and IG Studio lights. Contacted DAZ and was told they could not recreate the conditions that were causing the area lights to crash Studio, was also told that IG Studio lights don't work in Studio 4.5 and was offered a refund if the purchase was less than 30 days (which I didn't take them up on).

    Seeing this thread I turned off Progressive Rendering and it worked, re-installed IG Studio Lights set up a scene and it rendered fine, so now I am a happy chappy, Thanks again barbult and Luci45

  • MythmakerMythmaker Posts: 255
    edited December 2012

    I've just updated my Daz4 to 4.5pro a few days ago so I have the latest build. Learning to render with 3delight. Testing a simple scene with Tori Genesis, with one single IBL sphere with Uber Area Light base. Encountered the same crash issue above. Eventually found the 'turn off progressive rendering" solution. Works for me now. Thanks a bunch guys and gals. Amazing my 64bit x5670 (i7 equiv) with 12G RAM can't handle the spike...

    Now to the next render weirdness.. Tori's skin rendered with vertex lines. I loaded Gabi material on her, same issue. The render settings I use is the default one. Am I missing something obvious? Please advice.

    daz_render1.jpg
    802 x 609 - 83K
    Post edited by Mythmaker on
  • MachieltjeMachieltje Posts: 0
    edited December 1969

    Ok just out of curiosity; what is the point on progressive rendering sounds to me it's actually bloody useless.


    Also I'm sometimes seeing the same weird artifacts as in the post above when using UE2 so a why would be appreciated

  • SzarkSzark Posts: 8,765
    edited December 1969

    Shading Rate to low, as in too high a value...lower is better...higher is not. :)


    In the Advanced Render Settings Pane look for the shading rate and lowered it to , start at .50 and do a test render or lower until it disappears.

    These settings is your main Quality control centre. The only other areas of quality you need to take in to consideration is UberEnvironment2 (UE2) as it has some further controls included which need adjusting too Learning UberEnvironment2


    Old but good info on Render settings

  • MachieltjeMachieltje Posts: 0
    edited December 1969

    Szark said:
    Shading Rate to low, as in too high a value...lower is better...higher is not. :)


    In the Advanced Render Settings Pane look for the shading rate and lowered it to , start at .50 and do a test render or lower until it disappears.

    These settings is your main Quality control centre. The only other areas of quality you need to take in to consideration is UberEnvironment2 (UE2) as it has some further controls included which need adjusting too Learning UberEnvironment2


    Old but good info on Render settings


    I actually knew about the shading rate but in some cases that just doesn't seem to do the trick, so I was sorta hoping there was something I missed somewhere.

  • prixatprixat Posts: 611
    edited December 2012

    The actual cause of the mesh showing is most likely Shadow Minimum Bias settings too low.

    Sometimes a finer shading rate will solve it, sometimes you can increase the subdivisions, sometimes even a change of camera angle!
    Changing the Shadow Bias should always solve it. Every light has its own Shadow Bias setting (including UE) so you have to find the one that's causing it.

    Post edited by prixat on
  • MythmakerMythmaker Posts: 255
    edited December 2012

    Hi all, thanks for the feedback.

    I tried adjusting shading rate all the way down but it didn't resolve the mesh lines issue. After a whole day of trials and errors (resintalling characters and material files) I discovered the culprit is the very first HDR image I used for the IBL sphere. So for whatever reason that particular jpg causes those artifacts. Switching the pics to a few other equally huge 5000x2500 jpgs seem to be fine. So far. Will keep the forum posted just in case others bump into similar issues.

    Post edited by Mythmaker on
Sign In or Register to comment.
Rocket Fuel