How do you install Darkside Style/Layout to DS 4? SOLVED!!!

Miss BMiss B Posts: 3,069
edited November 2012 in Daz Studio Discussion

OK, I've finally installed DS 4 64-bit to my newish laptop, but I'm having a problem installing the Darkside Style/Layout addon.

First I'm on Win7 Pro with XP Mode, and I don't install any software to Program Files or Program Files (x86). Instead I install to folders at the root of C:\ called 2D Applications and 3D Applications.

That said, the Darkside installer only asks if I want Start Menu shortcuts or an Uninstaller when I choose Customize Install, but it doesn't ask where I have DS 4 installed.

Needless to say, nothing's happening. Anyone have any ideas on how to get this installed to my DS 4 installation? Any and all suggestions, tips or workarounds would be greatly appreciated, as I really hate the look of DS 4 by default.

Post edited by Miss B on

Comments

  • SzarkSzark Posts: 8,781
    edited December 1969

    I think depending which version you have Darkide could already be installed with the program....did you look in Window > Style > Select Style to see if it is there already.

    If not from memory I don't think it asks where to install as it will read from the registry where Daz Studio is installed. Mind you it has been a while.

  • Miss BMiss B Posts: 3,069
    edited December 1969

    That's the problem in a nutshell Pete. I installed DS 4A and it's only included with DS 4P. You are correct that it doesn't ask where to install, and it's obviously not reading the installation path from the registry, so now I'm stuck without it unless someone else has had this problem and found a way to overcome it. I so hate the default look of DS 4.

  • Richard HaseltineRichard Haseltine Posts: 19,852
    edited December 1969

    Have you installed DS4.5 Pro? I'm not sure what would happen if you entered your Advanced serial number, but I'm not sure it would matter (the only thing the free pro serial doesn't give you is Decimator, and I don't think Advanced had that either).

  • Miss BMiss B Posts: 3,069
    edited December 1969

    Decimator's listed on that popup that shows plugins that you have to enter serial numbers for, but then again, I would assume whichever s/n you use, that would allow for certain plugins to become active when you enter the appropriate s/n for it.

    My problem is, I don't want to deal with 4.5 Pro at this point as I'm not ready to deal with file formats other than what I'm used to in the older versions. At least for now. I do think, however, I can add the DS 4 Pro s/n I have and see if that works. I don't recall now if there was a separate s/n issued when DS 4.5 Pro update came out. I downloaded it, but keep it in a separate folder from the original DS 4.0. If it's the same s/n for both Pro versions, then that may be my answer. I'll try that and see what happens.

  • SzarkSzark Posts: 8,781
    edited December 1969

    I remember when I purchased DS4Advanced and I did have to install Darkside seperately and yes no Decimator for any version.

  • Miss BMiss B Posts: 3,069
    edited December 1969

    Well I tried the DS 4 Pro s/n but that only opened up all but the Decimator, and I think aniMate2 plugins. I just don't understand why the Darkside installer isn't working unless, and this is a guess on my part, it's because I install my apps in locations other than C:\Program Files for 64-bit, and C:\Program Files (x86) for 32-bit. I would've thought your initial comment about the registry directing it to the install would work a treat, but it didn't, and the uninstaller it's supposed to create doesn't exist even though the Start Menu folder has a shortcut that states it's in the C:\ root directory. Either it doesn't really install, or it's lost somewhere and I just don't feel like searching the whole hard drive for it.

    Anyway, I guess no one else has come across this problem, so I may give DAZ a call during the week and see if they have any suggestions. Why they didn't do what they did with the plugins and just make it available to those with the proper s/n, I don't know, but they must've had some reason for it. ~sigh~

  • SzarkSzark Posts: 8,781
    edited November 2012

    Sorry I am no help Miss B and yes I have never come across this.

    On a side note I never ever install Daz Studio in Program Files, yeah I know folks do and it is ok if it is just the software and not content and in doing so I hardly get any content or installing issues...only crashing at render time...still. But I might as well face facts that it is my old computer after all seeing I can't get a cleaner install than I have now.32bit with 3 GB of ram is no good for how I used to use Daz Studio so I am back with 3A.

    Post edited by Szark on
  • Richard HaseltineRichard Haseltine Posts: 19,852
    edited December 1969

    Pro and Advanced of a given version use the same file formats - the difference is only in which add-ons are activated (and available fro download). Older versions of DS didn't include the Darkside style - exactly which version are you using?

  • Miss BMiss B Posts: 3,069
    edited December 1969

    DS 4.0.3.47, which I first registered with the "Advanced" serial number, and then I re-registered it with the "Pro" serial number which, as you stated, opened up all but the Decimator and aniMate2 plugins.

    I've been using DS 3 Advanced on this laptop since I got it the beginning of the year, and I know it and DS 2 (which I used on my old laptop) didn't come with Darkside.

  • FixmypcmikeFixmypcmike Posts: 12,129
    edited December 1969

    I'm pretty sure 4.0.3.47 had Darkside built in.

  • SpottedKittySpottedKitty Posts: 3,404
    edited December 1969

    Miss B said:
    I've been using DS 3 Advanced on this laptop since I got it the beginning of the year, and I know it and DS 2 (which I used on my old laptop) didn't come with Darkside.

    It wasn't needed back then — the Darkside style is apparently the closest we're ever going to get to the old Classic style, which wasn't included in D|S4 and many people have been asking, begging and pleading for it ever since. DAZ just doesn't want to know.

    FWIW, the separate Darkside installer is only for D|S versions that don't have it incorporated in the main program installer — if you run it after installing a D|S version that includes it, you'll overwrite the files with possibly older ones that might not work. If anyone's done that by mistake, the only solution is to re-install D|S.

  • niccipbniccipb Posts: 0
    edited December 1969

    Hi Miss B...

    DS 4.0.3.47 does not have the Darkside style built in, so you do need to run the separate installer. I think Darkside_1.2_ds was the last one before it was built in to the DS installer...

    Just to see if your install path was the problem, I installed 4.0.3.47 on another laptop I have, and installed it to C:\DAZ instead of Program Files... and then ran the Darkside installer, choosing custom...

    In the Installation Summary window you should see the install path for DS 4, it should look like this...

    DAZ Studio 4.x Files Path:C:\ your path

    If the field is blank, then the Darkside will not install, even though the installer completes... If it shows a different path, navigate to that location after the installer completes and look for the file Darkside.style, and move that to the resources\style folder in the folder that you installed DS 4 to...

    For my test install, it did install the Darkside to the correct path and is available and working in DS 4

    The only difference between my install and yours is that the laptop I used is 32 bit Win 7 Home and not running XP mode, so I installed the 32 bit DS... I don't know how much if any difference that makes though...

    I hope you get it sorted out... :)

  • Miss BMiss B Posts: 3,069
    edited December 1969

    niccipb said:
    Just to see if your install path was the problem, I installed 4.0.3.47 on another laptop I have, and installed it to C:\DAZ instead of Program Files... and then ran the Darkside installer, choosing custom...

    In the Installation Summary window you should see the install path for DS 4, it should look like this...

    DAZ Studio 4.x Files Path:C:\ your path


    This is the problem!!! The only thing I have when I click Custom Install is 3 checkboxes for shortcuts in the Startup Menu and the Desktop, and to create the Uninstaller. I'm NOT getting the path box with a "browse" button. If that were the case I wouldn't have a problem.

    I have two installers, the older one I got when I bought DS 4A and it was called DarksideTheme_1.2. The newer one I got with DS 4P and it's called Darkside_1.2. Neither of them have that path field. Sot it seems that it's the installer that's the problem and not where I installed DS 4. Sheesh. I'll reset my downloads again, because I'm not sure whether it's been corrupted. I'll have to see.

    Thanks for at least letting me know I'm not going crazy.

  • Miss BMiss B Posts: 3,069
    edited November 2012

    OK, I was wrong, there is a "path" field, but it doesn't say "DAZ Studio 4.x Files Path". It says, "Start Menu Folder: DAZ 3D\Installed Content\Darkside", so I still can't install it. This is very weird.

    Here's a screenshot of what I'm seeing when I click on Custom Install.

    DarksideThemeInstaller.jpg
    670 x 392 - 66K
    Post edited by Miss B on
  • niccipbniccipb Posts: 0
    edited November 2012

    Hi...

    When you click Next you should see the Installation Summary like the pic below. The path should be to where DS 4 is installed... if not, then that's why it's not installing... I don't know why it's not reading your DS install path

    nicci... :)

    edit: this pic was from my 4.5 computer, but it is the same on the 4.0 install I did...

    edit2: the installer doesn't ask for your DS4 install path, it just finds it and displays it in the summary box... you can't change it

    darkside_intaller.JPG
    668 x 390 - 42K
    Post edited by niccipb on
  • Miss BMiss B Posts: 3,069
    edited December 1969

    And that's my problem. The screenshot below doesn't have the path showing. I have no idea why it's not finding my DS 4.0 installation. As Pete had mentioned earlier, he thought the installer would pick up the path from the registry, but obviously not. I may have to reinstall it, but I don't know if that will fix the problem.

    DarksideInstaller2.jpg
    671 x 395 - 71K
  • Miss BMiss B Posts: 3,069
    edited November 2012

    @nicci - YAY!!!!!!!!!!!!!!!!!!!!!!!!

    Uninstalling and reinstalling DS 4.0 did the trick. I don't know what happened the first time around, but this time it worked. I am SUCH a happy camper right now I feel like doing an Irish Jig at 2:05am in the morning. :coolgrin:

    NOW I can log off and get some sleep.

    Thanks for the help and encouragement guys, it means a lot. :-)

    Post edited by Miss B on
  • niccipbniccipb Posts: 0
    edited November 2012

    Hi...

    Just posted when you did... :lol:

    I was at a loss on this... I'm glad you got it all fixed now...

    nicci... :)

    Post edited by niccipb on
  • SzarkSzark Posts: 8,781
    edited December 1969

    niccipb get superhero status for coming to the rescue...great stuff.

  • Miss BMiss B Posts: 3,069
    edited December 1969

    Amen! I'm very happy everything worked out, and not just because of Darkside. Who knows what other problems I might have encountered if the initial installation was flawed and I didn't know it.

    You guys are the best. :-)

Sign In or Register to comment.
Rocket Fuel