Delivery Driver For Genesis does not load in Daz Studio 4.5

hedimininhediminin Posts: 7
edited December 1969 in The Commons

Hello, I try to load the item DeliveryDriverForGenesis in Daz Studio 4.5 but nothing happens, it appears in the list of scene but is not displayed in the viewport.
Anyone else had this problem?
Thanks

Comments

  • JimmyC_2009JimmyC_2009 Posts: 8,356
    edited December 1969

    This is a clothing set for Genesis. You have to Select Genesis first in the Scene tab, then double click, or drag and drop, the item onto Genesis.

  • hedimininhediminin Posts: 7
    edited December 1969

    I'm doing this, but the problem still occurs. :/

  • JimmyC_2009JimmyC_2009 Posts: 8,356
    edited December 1969

    If it is appearing in the Scene tab, then select it, and use the camera frame biutton to see if it is really there in the viewport.

    What version of DS 4.5 are you using, and what Operating System, and where are you loading these items from?

  • DWGDWG Posts: 772
    edited December 1969


    You have to Select Genesis first in the Scene tab, then double click, or drag and drop, the item onto Genesis.

    Whether or not Genesis is selected shouldn't make a difference, the clothing should load in both cases, but if Genesis isn't selected it won't be automatically fitted to him.

  • rocknrolla6527rocknrolla6527 Posts: 0
    edited December 1969

    I am having the same problem.

    DAZStudio_4.5.0.114_Mac64
    OS 10.6.8

    Everything loads but not the pants and shirt.
    The cap, the shoes, the props load perfectly.
    But not the pants and shirt, the guy was right it appears on the scene tab but not in the viewport.
    I even went as far as trying to render it to see if it would only appear in the render image but it does not either.
    Please help.

    Thank you.

    By the way I'm a beginner. If you could explain it in simple terms.

  • edited December 1969

    Yup...just purchased the outfit and have the same problem.

    I'm afraid I'm not too D|S savy, but came across this line in my log file:

    "WARNING: fileinput\dzassetdaz.cpp(1677): Could not find geometry definition: /data/Predatron/Delivery Driver/LSShirtPants/LSShirtPants.dsf."

    Guess I'll submit a bug report. I suggest others do the same.

  • rocknrolla6527rocknrolla6527 Posts: 0
    edited December 1969

    I actually sent a report already. have not received a reply yet though.
    I'll post it here as soon as I get it.

  • RiggswolfeRiggswolfe Posts: 627
    edited December 1969

    This is a problem I encountered on some other products. If you look, the outfit is most likely listed in your scene tab but there is nothing at all in surfaces when you select it. Here is my thread about it and how I "fixed" it. In short, you need to do some creative file editing to tell Daz where the geometry is.

    http://www.daz3d.com/forums/discussion/7423/

  • edited December 1969

    Was busy looking at files in a text editor and didn't see Riggswolfe's post.

    If you open up the geometry file, you'll see the id is blank. I went in and added the word "geometry".
    If you open up the ShirtPant file in the People/Genesis/Clothing/...folder, line 24 and 25 need to be edited.

    What is circled in red is what the two files should look like after editing.

    Pred.jpg
    1224 x 580 - 98K
    Pred2.jpg
    1206 x 539 - 75K
  • edited December 1969

    Now it loads and renders just fine.

    Delivery.jpg
    1080 x 906 - 539K
  • RiggswolfeRiggswolfe Posts: 627
    edited December 1969

    Looks like you found the same fix I did Phoenix. The odd thing about this issue is that Daz 3 and Daz 4 don't care about this ID so stuff loads just fine.

  • edited December 1969

    Yup...this outfit was created before 4.5, so it used to work just fine.

    It gets frustrating when there are obviously some minute changes in the versions that render previous items useless. I have the greatest admiration for plugin creators that seem to have to rebuild their products every time D|S gets an update.

    Thanks for posting the link to your thread. That should definitely help some folks out!

  • RiggswolfeRiggswolfe Posts: 627
    edited December 1969

    I added it to my signature because this is the second thread I've seen in two days. The odd thing if you read my thread is that another Daz user didn't have the issue when using the exact same products I had the issue with. (With one exception.) Our product versions and Daz versions were the same as well.

  • rocknrolla6527rocknrolla6527 Posts: 0
    edited December 1969

    Was busy looking at files in a text editor and didn't see Riggswolfe's post.

    If you open up the geometry file, you'll see the id is blank. I went in and added the word "geometry".
    If you open up the ShirtPant file in the People/Genesis/Clothing/...folder, line 24 and 25 need to be edited.

    What is circled in red is what the two files should look like after editing.


    How do I do this in a MAC with DS 4.5?
    Sorry I am not that techie.
    I am only using Daz because you simply double click to load characters and stuff.

  • RiggswolfeRiggswolfe Posts: 627
    edited December 1969

    I don't know how to do it in a mac but on windows the files can be edited with a text editor generally. Do NOT use something like Word that adds formatted or it will screw things up.

  • TotteTotte Posts: 7,067
    edited December 1969

    I'll take a look on OS X when I'm back inside (walking dogs right now)

  • rocknrolla6527rocknrolla6527 Posts: 0
    edited December 1969

    I see. I'll have to wait then. Thanks.

  • TotteTotte Posts: 7,067
    edited September 2012

    The file is indeed broken (anyone filed a content bug report yet? It wont be fixed without that).

    On Mac OS X, use TextWrangler (http://www.barebones.com/products/TextWrangler/) if you don't have it or any other pure text editor like sublime or hallon but not textedit as it might screw up the file encoding if you're unlucky.
    I cannot "fix the file" and put it here as it would probably violate the forum TOS.

    found the bug: https://bugs.daz3d.com/view.php?id=47887

    Post edited by Totte on
  • RiggswolfeRiggswolfe Posts: 627
    edited December 1969

    I'm not sure it's fair to the vendor to say the file is broken perse. The same file will load in Daz 4 fine and would load in Daz 3 if it could use Genesis. I know this from my own investigations into this. From what I can tell it appears that Daz 4.5 is simply more picky about stuff like this. Daz 4 and 3 seemed to just sort of ignore it if you didn't have the id and loaded the correct geometry anyway but 4.5 no longer does that. My guess is it was a stability fix that had an unintended consequence of making some files "broken".

    I've encountered it in cr2s as well from products I bought at Rendo and Runtime DNA. I can load them fine in Daz 3 and Poser but am unable to load them in 4.5 until I open the cr2 and manually add in that geometry ID.

  • TotteTotte Posts: 7,067
    edited December 1969

    Broken or broken, depends on what the specs says. I've got several items that has hard paths, not relative paths in cr2s and pp2 to the Runtime, like /Runtime or even some with C\:Devsusername\Runtime and not as it should be :Runtime , those are broken" as they do not follow the specs of now a cr2 or pp2 should be constructed, even if it works on the devs, machine and in Poser as Poser is pretty clever in locating misplaced files.

    And I don't say it's the devs fault (DAZ should have tested stuff with 4.5), we still get new releases with Duplicate ID errors fresh out of the store.

  • RiggswolfeRiggswolfe Posts: 627
    edited December 1969

    I'm much less forgiving of relative paths vs hard paths, it was dealing with that that first led me to download a cr2 editor and poke in those files. This issue though was one of those things that wasn't an issue before 4.5 but now it is.

  • TotteTotte Posts: 7,067
    edited December 1969

    Yes, but this issue is most likely due to a bug in 4.0. I've reported lot's of issues during DAZ 4.5 Beta but I just happened not to use the Delivery Driver outfit (just the shoes, best dress shoes yet for Genesis).
    So I must say that this is an issue where "we" testers or "DAZ ppl" should have found it, normally a fix for broken content takes a day or two.

  • TotteTotte Posts: 7,067
    edited December 1969

    Just got a note on mantis that it's been updated, reset, download and enjoy.

  • rocknrolla6527rocknrolla6527 Posts: 0
    edited December 1969

    Is there any way to make the texture of the clothing less shiny? where do i adjust it?

  • TotteTotte Posts: 7,067
    edited December 1969

    Is there any way to make the texture of the clothing less shiny? where do i adjust it?

    Reflection/Glossiness under the Surface tab

  • Richard HaseltineRichard Haseltine Posts: 19,963
    edited December 1969

    Totte said:
    Is there any way to make the texture of the clothing less shiny? where do i adjust it?

    Reflection/Glossiness under the Surface tab

    What you probably need to do is lower the Specular Strength, as well as or instead of the Glossiness.

  • TotteTotte Posts: 7,067
    edited December 1969

    Totte said:
    Is there any way to make the texture of the clothing less shiny? where do i adjust it?

    Reflection/Glossiness under the Surface tab

    What you probably need to do is lower the Specular Strength, as well as or instead of the Glossiness.


    Or add a very soft fine grained bumpmap or specularitymap to get uneven gloss

Sign In or Register to comment.
Rocket Fuel