Shredded mesh when rendering

frogdotfrogdot Posts: 0
edited October 2012 in Carrara Discussion

I came upon a new problem and wondered if it's known and what's the solution. Using Carrara 8.1.1, I had a character sitting on the floor, wearing long pants. When render was done, the pants had about three quarters of the polygons invisible making large jagged holes and the legs showed through. I made the legs invisible, then the figure, but it rendered the same. Tried two other pants, the same result. any ideas?


Post edited by frogdot on


  • holly wetcircuitholly wetcircuit Posts: 0
    edited December 1969

    frogdot said:
    Tried two other pants, the same result. any ideas?


    What "pants" are they? Have they ever worked in another scene or is this your first time trying them all? Are they from the same set? Are they actually a different model (OBJ) or all based on the same mesh?

    The likely issue is that the pants have flipped normals, but it would help if you can say where the model(s) came from and whether you added them natively (through Carrara's Browser) or imported them from another program...

  • frogdotfrogdot Posts: 0
    edited December 1969

    I appreciate the reply. As always seems to happen, I go back to work with the file and NOW everything renders OK, but that was after I deleted a V4 figure and other non-essential items. Last night I had saved and closed the program, then reopened it and had the same problem, and it was the same this morning. All with a V4 and M4 figure. I've never had a memory problem even using more than two figures. I also rendered with both figures, but deleted the pair of pants, then reloaded them and it came out OK. Weird. Glad it works, but would like to know what caused it.

    To your question, the item in the image are the 1930s Workman pants from Daz. I started with Uzilite's Beowulf pants and then BillyT's Real jeans. I've used them all before and used Carrara's browser.

  • holly wetcircuitholly wetcircuit Posts: 0
    edited December 1969

    Totally weird.... I have no idea...

    Just the usual recommendations (assuming it was some sort of memory allocation issue):

    Before saving, under the EDIT MENU

    1: remove unused objects
    2: remove unused shaders
    3: consolidate shaders

  • BurnartBurnart Posts: 0
    edited December 1969

    Looks like some kind of weird normals inversion.

Sign In or Register to comment.
Rocket Fuel