Ram Requirements for rendering

mark128mark128 Posts: 903
edited December 1969 in New Users

I searched the forums and DAZ site trying to find an answer, but could not find an answer.

I recently downloaded DAZ Studio 4.5 and have been experimenting around with it. My computer is less than ideal. It is a old 32 bit Windows XP machine with 2 gb of RAM.

I have been experimenting around creating some simple images, experimenting with lighting and rendering options. The 3Delight software rending option produces nice results with nice lighting and shadows. Unfortunately if I try to render a simple image like the one attached much bigger than 600x463 it crashes. Sometimes it gives resource errors, sometime it crashes without an error.

I assume this is because the software rendering requires more RAM than available on my computer. I need a 64 bit Windows 7 machine with a lot of RAM. Is this probably the problem?

How much RAM do you need to render image using the 3Delight software rendering at 1024x768 up to say 1600 x 1200? Is 8 gb enough? 16 gb? 32 gb? How much RAM can DAZ Studio make use in the windows 64 bit version.

Comments

  • JaderailJaderail Posts: 0
    edited December 1969

    Yes, Ram is the answer. I'm Win7 64bit at 8Gb ram and I have not hit the limits of my render size or items/textures/render settings used. I have done 4000x2500 at high render settings with everything I wanted in the render without going above about 85% Ram used.

  • patience55patience55 Posts: 6,194
    edited December 1969

    If you can manage to get a computer with lots of memory AND W7Pro, it can handle more memory than W7 home.

  • FixmypcmikeFixmypcmike Posts: 12,154
    edited December 1969

    In the interim, there are some things you can do to cut down on RAM needed. Textures are a big part -- if the texture map for character's face is 4096x4096, but it only occupies 100x100 pixels on your image, you can create a reduced version of the texture to use for that image. It's also helpful to remove anything from the scene that isn't visible (or casting visible shadows or reflections). It also helps to save your scene and close DS, then restart it and reload the scene to render.

  • mark128mark128 Posts: 903
    edited December 1969

    Thanks for the advice.

    I am aware the Win 7 pro will support more than 16 gb of ram, but I'm not sure it is worth the expense to get 32 gb of ram. It sounds like 16 gb will be enough. Is this true? Would there be benefit to getting 24 gb? or 32 gb?

  • JaderailJaderail Posts: 0
    edited December 1969

    I'm on 8GB and very few scenes push my Ram used above 80%. Some sets do slow my PC way down. But that's more my GFX card, it handles the viewport.

  • SzarkSzark Posts: 8,781
    edited December 1969

    mark said:
    I searched the forums and DAZ site trying to find an answer, but could not find an answer.

    I recently downloaded DAZ Studio 4.5 and have been experimenting around with it. My computer is less than ideal. It is a old 32 bit Windows XP machine with 2 gb of RAM.

    I have been experimenting around creating some simple images, experimenting with lighting and rendering options. The 3Delight software rending option produces nice results with nice lighting and shadows. Unfortunately if I try to render a simple image like the one attached much bigger than 600x463 it crashes. Sometimes it gives resource errors, sometime it crashes without an error.

    I assume this is because the software rendering requires more RAM than available on my computer. I need a 64 bit Windows 7 machine with a lot of RAM. Is this probably the problem?

    How much RAM do you need to render image using the 3Delight software rendering at 1024x768 up to say 1600 x 1200? Is 8 gb enough? 16 gb? 32 gb? How much RAM can DAZ Studio make use in the windows 64 bit version.

    I know 2GB isn' t much but I have 3.25 and I have had the same problem since DS4.5.0.114 to the latest build.

    Can someone explain to me why I can't render a simope scene made in DS4.5.0.114 or latter but I can render that same scene in DS4.5.0.049 RC2 and not DS4.5.0.114 and later. Oh simple things like one clothed Genesis I can render with out crashing, as soon as I add say the new PC Pickup, render crash and burn.

    Same computer same everything, just rolled back until I hit the stable version, which for me is DS4.5.0.49 RC 2.

    Everything is up to date, drivers, C++ etc. Grahpics card HD5450 has never been a problem before.

    Since no one could help before when I posted this I will have to either not use Daz Studio and go on to Poser 8 or roll back to DS4.5.0.49 RC 2 in the meantime. But it is getting to the stage where I am losing my temper with it and for me that is saying something

  • JaderailJaderail Posts: 0
    edited December 1969

    Szark I think what you are running into is not a DS issue but a 3Delight Issue. All the versions of D4 to DS4.5-6 use different versions of the 3Delight Render engine. Example, the loss of Uber Area lights in 4.5 114 was a 3Delight error not a DS error 4.5 6 is a newer 3Delight than the 4.5 114 so they work once again.

  • RedHeadLilithRedHeadLilith Posts: 0
    edited December 1969

    Jaderail said:
    Yes, Ram is the answer. I'm Win7 64bit at 8Gb ram and I have not hit the limits of my render size or items/textures/render settings used. I have done 4000x2500 at high render settings with everything I wanted in the render without going above about 85% Ram used.

    wish that was the case for me I have the same computer as you but still crashing

  • SzarkSzark Posts: 8,781
    edited December 1969

    Thx Jad I know you are trying to help but I know all that but in my mind it is Daz3D's problem and shouldn't be mine. :) Arrrrrrrrrrrrrrrrrrrrrrrrrrrrrrr

    So my theroy sounds right.

    My thoughts were that it is a trade off for getting better and faster rendering. What irks me is that I am not using serious advanced lighting, only 330000 faces in the scene which is half of what I could use before.

    I am not even super sampling at render times and still poof. For me it getting to the piint of UNUSEABLE. The only reason I have the latest build installed is so I can help folks. Now I will have to go away and make a choice, help me or help others. That is a hard one for me.

  • JaderailJaderail Posts: 0
    edited December 1969

    Jaderail said:
    Yes, Ram is the answer. I'm Win7 64bit at 8Gb ram and I have not hit the limits of my render size or items/textures/render settings used. I have done 4000x2500 at high render settings with everything I wanted in the render without going above about 85% Ram used.

    wish that was the case for me I have the same computer as you but still crashing

    This one I can not figure out. It must have something to do with the way we all have our PC's set up differently. Example: I'm the only user so I have the UAC set to off because I will never need to set some software for use by other users. I never use any MS anything, firewall, maleware or others, I use programs I trust. And I use several addons for AV, Regeristry watching, firewall and trojan blocking. Every system is Different due to User settings. That is all I can think of when people with the same Power get different results with the Same Program.

  • JaderailJaderail Posts: 0
    edited December 1969

    Szark said:
    Thx Jad I know you are trying to help but I know all that but in my mind it is Daz3D's problem and shouldn't be mine. :) Arrrrrrrrrrrrrrrrrrrrrrrrrrrrrrr

    So my theroy sounds right.

    My thoughts were that it is a trade off for getting better and faster rendering. What irks me is that I am not using serious advanced lighting, only 330000 faces in the scene which is half of what I could use before.

    I am not even super sampling at render times and still poof. For me it getting to the piint of UNUSEABLE. The only reason I have the latest build installed is so I can help folks. Now I will have to go away and make a choice, help me or help others. That is a hard one for me.

    I agree, Szark. I'm sorry you will need to make such a choice. But in my eyes we should all do what is best for us. The only good I can see is that you will still be around and be able to Help the others who are like you and only use 4.0. I still see many of them.

  • RedHeadLilithRedHeadLilith Posts: 0
    edited December 1969

    Jaderail said:
    Jaderail said:
    Yes, Ram is the answer. I'm Win7 64bit at 8Gb ram and I have not hit the limits of my render size or items/textures/render settings used. I have done 4000x2500 at high render settings with everything I wanted in the render without going above about 85% Ram used.

    wish that was the case for me I have the same computer as you but still crashing

    This one I can not figure out. It must have something to do with the way we all have our PC's set up differently. Example: I'm the only user so I have the UAC set to off because I will never need to set some software for use by other users. I never use any MS anything, firewall, maleware or others, I use programs I trust. And I use several addons for AV, Regeristry watching, firewall and trojan blocking. Every system is Different due to User settings. That is all I can think of when people with the same Power get different results with the Same Program.

    I agree with you I think most problem I'm having isn't daz related but the fact I know so little about computers and how to handle them .
    my Bf tried to help me but looks like he also did few mistakes
    I don't blame anyone but myself

  • mark128mark128 Posts: 903
    edited December 1969

    As I posted in the other thread, I got a chance to try DAZ on a 64 bit Windows 7 system with 4 GB of ram. It is really like night and day. I was able to render scenes with more objects and much larger sizes and there were no crashes.

    I monitored memory usage using the task manager. Memory usage did not seem that much higher than on my 32 bit system where it would frequently crash.

  • Takeo.KenseiTakeo.Kensei Posts: 935
    edited December 1969

    Szark said:
    I know 2GB isn' t much but I have 3.25 and I have had the same problem since DS4.5.0.114 to the latest build.

    Can someone explain to me why I can't render a simope scene made in DS4.5.0.114 or latter but I can render that same scene in DS4.5.0.049 RC2 and not DS4.5.0.114 and later. Oh simple things like one clothed Genesis I can render with out crashing, as soon as I add say the new PC Pickup, render crash and burn.

    Same computer same everything, just rolled back until I hit the stable version, which for me is DS4.5.0.49 RC 2.

    Everything is up to date, drivers, C++ etc. Grahpics card HD5450 has never been a problem before.

    Since no one could help before when I posted this I will have to either not use Daz Studio and go on to Poser 8 or roll back to DS4.5.0.49 RC 2 in the meantime. But it is getting to the stage where I am losing my temper with it and for me that is saying something

    I think there's a problem with the recent 32bit version. The 64bit works without problem on my comp (W7 64bit 12 Gigs Ram)
    I cant't render with any of the two last 32bit official build. It crashes.
    I'll make another test with an other PC

  • Roman_K2Roman_K2 Posts: 97
    edited December 1969

    FWIW I like to pick my render sizes like this: 1111 pixels wide, 2222 pixels wide, 3333 and so on.
    Reason: it saves typing and having to think about it too much, eg. it gets me out of the starting gate a bit faster, especially at the beginning of a new composition when I just want to see what is going on so that I can decide whether or not to take it further. Then I move up to 4444, and 5555 pixels and so on which I THINK is where the trouble starts esp. with complicated models like the Back Alley prop and the Blenworth castle... with these I start real slow as I don't want to push my luck if a one-hour render isn't going to work anyway?

    My 64-bit Windows Vista machine has 4 Gb RAM. I've got one of the latest betas of DS 4.5 -- number 137 or 141 IIRC.

    On my older, 2 Gb Thinkpad with XP and DAZ Studio going back to February 2012, I believe it is, I'm pretty sure I'm good for 4444 pixels wide and maybe 5000 pixels but it can take an hour and a half and some renderings fail by coming out solid black. So I try to keep it lower than 4000 say. Depends what I want and the degree of postwork that I want to apply later.

    Other than stability which has been important of recent >:( I'm a lot more interested in lighting and the moods I can achieve, than I am in the maximum size of my renders. I'm happy exploring the models and their nooks and crannies and even at 1920 x 1080 there's an awful lot to look at?

    back-alley.jpg
    720 x 576 - 46K
  • SzarkSzark Posts: 8,781
    edited December 1969

    Szark said:
    I know 2GB isn' t much but I have 3.25 and I have had the same problem since DS4.5.0.114 to the latest build.

    Can someone explain to me why I can't render a simope scene made in DS4.5.0.114 or latter but I can render that same scene in DS4.5.0.049 RC2 and not DS4.5.0.114 and later. Oh simple things like one clothed Genesis I can render with out crashing, as soon as I add say the new PC Pickup, render crash and burn.

    Same computer same everything, just rolled back until I hit the stable version, which for me is DS4.5.0.49 RC 2.

    Everything is up to date, drivers, C++ etc. Grahpics card HD5450 has never been a problem before.

    Since no one could help before when I posted this I will have to either not use Daz Studio and go on to Poser 8 or roll back to DS4.5.0.49 RC 2 in the meantime. But it is getting to the stage where I am losing my temper with it and for me that is saying something

    I think there's a problem with the recent 32bit version. The 64bit works without problem on my comp (W7 64bit 12 Gigs Ram)
    I cant't render with any of the two last 32bit official build. It crashes.
    I'll make another test with an other PC

    Thanks Takeo

  • Takeo.KenseiTakeo.Kensei Posts: 935
    edited December 1969

    You're welcome Szark.

    Status is following.

    On my Desktop PC I saw once that DAZ had a problem with SYSWOW64. So I did some Windows updates and after reboot DS4.5 32 bit was a bit better. I managed to render some little scenes as well as a bigger scene that took 1,5 Gigs memory. However I also had some random crashs and also had the "memory error" message once. And I never had that with the 64 bit version. As it crashes randomly on little and mid scenes and I have more than enough RAM, I'm pretty sure that there is something. The odd thing is that some windows updates did arrange the thing a little bit or I had no luck the other day.

    On my notebook Quadcore i7 Win7, 8 Gb Ram and 2 Gb Nvidia Quadro I tried 3 times to open some little scene and to render, without success till now.

    I'll go on testing and tell you what I get.

    The only thing I'm sure of is that the 32 bit RC1 didn't have these problems so going back to RC1 or RC2 could be a good idea if they were working for you

  • SzarkSzark Posts: 8,781
    edited October 2012

    Yeah I have been doing some testing myself. DS4.5.1.6

    I made a simple scene using Genesis, Supersuit, Cape, ground plane, cube and Pickup. 3 Unber spots and Uber Environment. Tried to render the scene at mid quality settings for both Uber and render settings....crashed every-time. Tried really low settings and still crashed

    I then turned off SubD for Genesis and Supersuit, crash
    Removed displacement and reflections for Supersuit and Cape, crashed
    Removed Genesis and clothing, rendered every-time.
    Decimated Genesis and clothing, imported the Decimated OBJ in to the scene and it renders when it feels like it but I does render out at fairly high quality.

    The weird part about all this is that the background of this image I am making which I am rendering separately took 14 hours to render and not one crash. But it didn't have much geometry in the scene.

    So yeah I am at a loss to what is going wrong still.

    Post edited by Szark on
Sign In or Register to comment.
Rocket Fuel