DS 4.5 not saving zeroed out morphs in Hair

larsmidnattlarsmidnatt Posts: 3,453
edited October 2012 in The Commons

Many of you may be familiar with how hair follows elf ears and the workaround, and that is where I am having a problem now.

In 4.x I would show hidden properties for the hair and zero out the elf ear morph. When i would save the daz file this was remembered.

Now with 4.5 I have to keep zeroing out the ear morph every time I load the scene. Anyone else experience this issue? I'm not sure if this is exclusive to one hair style or not, I'm kinda in a rush on a project and will try a different one later. the hair I'm using in a bunch of renders now is 1930's Female Hair for Genesis.

Post edited by larsmidnatt on

Comments

  • BejaymacBejaymac Posts: 1,043
    edited December 1969

    Technically speaking none of your conformers actually have the morphs in them, so every time you load your duf scene DS will apply the auto follow morphs to the conformers, so there really isn't anything there for it save.

    The morph in Genesis needs edited to remove the auto follow function from it, either by DAZ fixing their cockup or by the user editing the files.

  • Richard HaseltineRichard Haseltine Posts: 19,957
    edited December 1969

    As far as I am aware the morphs are generated in the conformers the first time they are turned up in the figure, and the result then persists and should be saved with the item/scene. I think I recall seeing something about this in the change log - larsmidnatt, are you using the release or the newer beta version of 4.5?

  • BejaymacBejaymac Posts: 1,043
    edited December 1969

    Richard the morphs need to be saved into the conformer's data folder as morph assets before they will show in the DUF, only then will the settings be saved.

    I'm using the beta and have created a character using the basic female morph and quite a lot of dietrying's morphs, I conformed the K4 tankini & briefs to my character and saved as a scene, the only modifiers listed in the duf for the tankini & briefs is the basic female morph as DAZ included that in each conformer. I then redid the scene, this time I used a conformer with no morphs built in, the resulting DUF only had skinbinding listed for the conformer, all the rest were assigned to Genesis.

  • MurgatroydMurgatroyd Posts: 585
    edited December 1969

    Possible workaround: instead of zeroing the morph, try setting it to a very small nonzero value (e.g. 0.001). If the cause of the problem is what I suspect, this should avoid it.

  • Richard HaseltineRichard Haseltine Posts: 19,957
    edited December 1969

    if the morphs aren't saved as an asset they should be saved locally, in the .duf (which will be larger as a result). Of course that may not be happening, but that's my understanding of what should be happening.

  • larsmidnattlarsmidnatt Posts: 3,453
    edited October 2012

    thanks for the replies I lost track of this thread when I got email bombed wih 104 notifications. I'll try saving with a small value and see if that works. Thanks

    EDIT: nope that doesn't work. putting in a value doesn't stay when you save and reload. I'm using 4.5 official release and not betas

    Post edited by larsmidnatt on
  • cwichuracwichura Posts: 1,000
    edited October 2012

    The .137 beta fixes many DUF bugs; I would strongly recommend switching to it. It may not fix your particular bug, but it will fix other save issues in the official release. (I know because I submitted several that were fixed, and I've seen others listed in the bug tracker, as well.)

    If you still experience this problem with .137, then I would recommend you report it as an issue at https://bugs.daz3d.com/ . DAZ seems particularly sensitive to bugs in the new DUF format, and has been very responsive in fixing them.

    Post edited by cwichura on
  • BejaymacBejaymac Posts: 1,043
    edited December 1969

    IMHO this is more a content bug rather than a DS bug, the active morph transfer system should never have been turned on for many of the Evo head morphs, but because someone came up with a "half-assed" work around DAZ haven't bothered to fix them.

    Back when this problem was first discovered I advised people to edit the morph to turn off the active morph transfer system, I get the feeling I was pretty much ignored, well you got two choices now, either bitch to DAZ to get them to fix the morphs, or do it yourself, which btw is just as easy for you to do in DS as it is for DAZ to do.

  • larsmidnattlarsmidnatt Posts: 3,453
    edited December 1969

    Ok thanks folks. Not sure I want to go to a beta version at this point since I'm in the middle of a project(s). I guess I'll keep an eye out for an official release.

  • Hiro ProtagonistHiro Protagonist Posts: 321
    edited December 1969

    I have the 4.5 beta version and I still have this problem (admittedly I didn't try the "small value" suggestion).

  • BejaymacBejaymac Posts: 1,043
    edited December 1969

    Clear the scene and load in Genesis, in the Parameters tab find the morph that's causing your problems, if you dial it make sure you zero it again before continuing, (pic 1a) click on the "cog" and in the new menu select "Parameter Settings...", a new window will appear (pic 1b), uncheck the box for auto follow and click Accept.

    That's you removed auto follow for the morph as it is inside the Genesis you have loaded into the scene, now you need to add that alteration to the file in the data folder. For this you go "File > Save as > Support Asset > Save modified assets", after you click on this DS will have a quick scan of Genesis and should create a new window (pic 2), the files listed in here are the ones it's going to alter, as long as the listed file resembles the name of the morph (it wont be identicle if it's a DAZ morph) then your safe to click accept.

    You can now clear the scene and load in the duf scene you were having issues with, in the case of the ear morph they should now be poking through the hair, rather than the hair being distorted.

    Goodbye.jpg
    274 x 277 - 67K
    Fixed.jpg
    610 x 408 - 215K
  • larsmidnattlarsmidnatt Posts: 3,453
    edited December 1969

    very cool thanks much

Sign In or Register to comment.
Rocket Fuel