Content Library categories half-broken

I used the .rsr converter mentioned here in this thread. When I used it on on the files in My Library, it worked great. But then I went to my content library categories, and a bunch of icons are missing. The folders are there, but nothing's inside them.

For example, the PD Priscilla freebie is visible(and loadable) from the runtime part of the content library, but when I go to my categories and try to load it from there, the icons just aren't there. I've shut DS4.5 pro down and reopened it. I've restarted my computer, and I've tried reinstalling and re-categorizing PD Priscilla as well, but that didn't work. The thing with this is that PD Priscilla didn't have any rsr files to begin with, just .pngs.

I have no idea what to try next.

Thanks for your help.


  • FixmypcmikeFixmypcmike Posts: 17,300
    edited December 1969

    Do you mean the item isn't therer at all, or that it appears with a triangle and exclamation point on the icon? Can you give the complete path and filetype of the item, and exactly where in the Content Library you're looking for it?

  • edited December 1969

    Thanks for the reply. The items don't appear to be there at all. In the example I'm using, the entire PD Priscilla character is missing in my cataloged files, but is perfectly usable from the runtime folder. I'm uploading screen shots of (hopefully in this order): 1) the original path and what some of the items look like in the runtime folder, 2) where I've cataloged it in my personal categories with it being clear nothing is showing up, 3) the file pathway with some of the files in the folder. (The picture was too big to upload, I think, so I cropped it.)

    737 x 585 - 132K
    800 x 574 - 114K
    800 x 601 - 137K
  • FixmypcmikeFixmypcmike Posts: 17,300
    edited December 1969

    Strange -- what method did you use to categorize? Exact steps if you can.

  • edited October 2012

    Well, it was already categorized and working properly before I ran that rsr to png converter. Also, I've tried categorizing other things since all this happened (e.g. Victoria 3 base) and it worked just fine.

    I tried two ways, both of which give the same result here.

    1) In the runtime folder, go to the pose folder, click on PD Priscella folder. Right click on the folder, select "create a category from" then select "This folder only." The Select a Parent category box pops up. I click the drop down arrow next to my Characters category, then the drop down arrow next to my Complete Category, then I select the V4 category and click accept.

    2) In the runtime folder, go to the pose folder, click on PD Priscella folder. Then select all the icons (ctrl+a) then right click and select "Categorize." In the Select Categories popup window, I click on Characters, then I click Complete, then I right click on V4 and select "Create New Category." I type in the name PD Priscella and click Okay. Then I click in the check mark box next to my new folder, PD Priscella, and click accept.

    One other thing I've noticed. The disappearing icons are only happening to some freebies. Never a daz-purchased item. But they were some pretty nice freebies, so I'd love to get them back into my categories.

    Post edited by aprilsunshine7_4526d47d74 on
  • FixmypcmikeFixmypcmike Posts: 17,300
    edited December 1969

    Make sure you delete the empty category first -- if you try to create a new category with the same name, I don't think it actually does anything.

  • edited December 1969

    I just tried that. Just in case, I closed DS4.5 after I deleted the container and before I recategorized it. But it didn't work.

    Is there anyway for me to actually access my categories database to see what's going on in that area? I know where the files are for it, but I don't know what program to open it in.

  • edited December 1969

    An update: I have found that the problem lies in my contentDB.dat file in my content management database. I have no clue what's causing it, and don't know how to open the file to get anything meaningful out of it.

    I tried to work around the problem by creating a new runtime, but that didn't work, either.

    I can roll my database back 3 weeks to my last backup so I won't lose everything, but I'll still lose a lot of work. Does anyone have an idea on how to fix the contentDB.dat file?


  • edited December 1969

    Thanks for the link. I followed it step by step, but the user settings aren't exported with the problem content database. (The popup window showing the progress disappears after a split second. My guess is that means it's not actually able to completely start the process.) When I roll it back to my 3 week-old backup, the process works just fine though.

    It looks like I'll need to recategorize everything I've done the last 3 weeks. Thanks for all your help, though.

Sign In or Register to comment.