What precautions are needed before upgrading 4.0 to 4.5?

Ferrio67Ferrio67 Posts: 0
edited December 1969 in New Users

I've tried looking around the forums here, but haven't found a topic thread specificly covering this. I've downloaded and saved D\S 4.5 to my harddrive and am looking to upgrade. However, I want to find out what I will need to do in preparation for the upgrade.

I have the 64-bit file stored seperately in a download sub-folder on my D drive. I also have ALL my dounloaded figures/meshes/clothing/props/etc. in a series of download sub-folders, also on my D drive.

Any and all help would be appreciated.

Comments

  • FixmypcmikeFixmypcmike Posts: 11,651
    edited December 1969

    1) Make sure you have the Genesis Starter Essentials downloaded as well -- the default content is no longer included in the application installer.
    2) Uninstall DAZ CMS before installing 4.5 -- it doesn't get uninstalled automatically, and some things don't work right if you have an older version of the CMS.

  • SzarkSzark Posts: 8,763
    edited December 1969

    I have learned as my cost to uninstall everything first now, Daz Studio, CMS amd plug-ins. I never had to do that with DS3 but now I find that to be the best approach.

    Most of my issues have gone since I did that.

  • Ferrio67Ferrio67 Posts: 0
    edited December 1969

    1) Make sure you have the Genesis Starter Essentials downloaded as well -- the default content is no longer included in the application installer.
    2) Uninstall DAZ CMS before installing 4.5 -- it doesn't get uninstalled automatically, and some things don't work right if you have an older version of the CMS.

    1) Yes, I just checked the folder and '14812_GenisisStartersEssentials_1.3_trx.exe' is there. I also read the PDF file, which says to load up D|S 4.5 then GSE.

    2) Sounds like a good idea, but wouldn't Szark's plan of uninstalling D|S 4.0 completely be better? (The only reason I'm NOT inclined to do that is that I have a few saved v4.2 'templates' - although I could probably redo them very quickly.)

    Anyways, thanks for the suggestions and help. I've been lax the last little while in getting in and learning the system. Been trying to save up enough to get a few needed items that I can't get as freebies - or substitute by using freebie stuff.

    (Which reminds me, know where I can find decent dirt road mats for a fronteir town setting?)

  • RedHeadLilithRedHeadLilith Posts: 0
    edited December 1969

    Szark said:
    I have learned as my cost to uninstall everything first now, Daz Studio, CMS amd plug-ins. I never had to do that with DS3 but now I find that to be the best approach.

    Most of my issues have gone since I did that.

    when you say everything what do you mean , do I need also to uninstall all the stuff from the store?

    I noticed that when I don't uninstall all the stuff from the store first and than re install them I keep getting this duplicate ID message every time I wanted to updated to the latest version and the plugin script on the forums that is offering to fix it didn't solved my problem

    so only going and uninstalling everything one by one and than re installing them again solved my problem...

    is there any other way to do this ? like a plugin that can uninstall all the stuff at once and than re install them again all at once?

  • SzarkSzark Posts: 8,763
    edited December 1969

    I never touch my content at all but I have updated all my Genesis content Updated Genesis Products List & Thing To Be Aware Of and so far I haven't had the duplicate id issues.

    Since using DS2 I have never had to worry about content uninstalling unless it is the Default Content..but now that is a separate install so the default content will get uninstalled with DS4 but as I said we have the default content in a separate install file to replace the uninstalled ones.

    But any content you have bought, freebies etc should all remain intact.

  • RedHeadLilithRedHeadLilith Posts: 0
    edited December 1969

    thank you for your comment , will know it now for future updated versions .

  • prixatprixat Posts: 608
    edited December 1969

    Ferrio67 said:
    1) Yes, I just checked the folder and '14812_GenisisStartersEssentials_1.3_trx.exe' is there. I also read the PDF file, which says to load up D|S 4.5 then GSE....

    With Studio 4.5.0.137, I got GenisisStartersEssentials_1.4

  • Ferrio67Ferrio67 Posts: 0
    edited December 1969

    When did you download your copy? Did they update the zip file after 5 PM EDT Wednesday? (Yes, I just checked, and that's when I downloaded it from the site.)

  • prixatprixat Posts: 608
    edited October 2012

    Whats the version number on your DS?


    Instead of resetting a previous DS from my account history, I ordered a new 'DS Pro Beta' from the store, back on the 17th September.

    (Its labeled BETA but it actually has some important fixes in it and has been completely stable on my win7 64bit 8GB machine.)


    ...and I took absolutely no special precautions, I let it detect and uninstall what it wanted and install where it wanted...

    I think of it as extreme sport: base jumping, swimming with sharks, installing DS... :coolsmile:

    Post edited by prixat on
  • NimosNimos Posts: 23
    edited December 1969

    What's all this about now? Do we need to delete all out Genesis stuff and re-download update Genesis stuff?

  • Richard HaseltineRichard Haseltine Posts: 19,401
    edited December 1969

    No, though if you get Duplicate IDs when loading a piece of content you should try getting an update, or run my fix script and update at leisure. If you use the Shaping pane you will also want to update some of the older morphs as they won't show on the shaping pane in 4.5 - but they will still be available through Parameters.

  • mjc1016mjc1016 Posts: 7,247
    edited December 1969

    Also, all the included shaders, hopefully have been recompiled, because the update includes a 3Delight version update (from 10.5something to 10.62)...I know I was getting a bunch of recompile messages (this shader should be recompiled...) on shaders I've personally made. Even ones I recompiled for 114. Not having recompiled shaders could be one reason for some slowdowns seen with 137. (I know that has been part of some of my slowness in 137...)

  • SzarkSzark Posts: 8,763
    edited December 1969

    Yeah noticing the recompling note a lot with Uber Products even the lights and pwSurface etc.

  • Richard HaseltineRichard Haseltine Posts: 19,401
    edited December 1969

    There are two messages - one saying that the shader must be recompiled, one that it should be recompiled. The current commercial shaders should all give the latter at worst - they will work, though it's possible that a recompiled version might be a bit faster. Shaders that weren't created with the DS4 tools, and shaders (such as ahEnvironment) that haven't been updated for DS4.x at all, will give the former and will, if you have the source, need recompiling.

  • SzarkSzark Posts: 8,763
    edited December 1969

    Thanks Richard for the info.

  • mjc1016mjc1016 Posts: 7,247
    edited December 1969

    Actually, most shaders can be recompiled, without the source, in the 10.x series of 3Delight. Just find the sdl files and go to the command line...then run shaderdl.exe (it's in the /Studio4/bin folder. It will recompile the shaders against the current version of 3Delight. It was a major feature of the 10.x series.

    And Richard...those with the message that states may be a bit faster if they are recompiled. then the initial time from clicking Render until it actually starts rendering (the setup/optimizing) time, on my system decreased significantly, after I manually recompiled them. Also remember that lights are shaders in 'Renderman-world', so the lights get it too...if needed.

    But using the updated content pack, should eliminate the messages/need to do that for any of the included ones, including the Uber items...

  • Richard HaseltineRichard Haseltine Posts: 19,401
    edited December 1969

    The DAZ shader creation tools add the needed lines for the sahder to recompile on the fly under 3DL 10.x, hence my earlier comment. And of course if you perform the recompile on the shader and save it that will give a faster start than having the recompile done on the fly - but the downloaded shaders needed to work in both DS4.0 and 4.5.

  • RedHeadLilithRedHeadLilith Posts: 0
    edited December 1969

    The DAZ shader creation tools add the needed lines for the sahder to recompile on the fly under 3DL 10.x, hence my earlier comment. And of course if you perform the recompile on the shader and save it that will give a faster start than having the recompile done on the fly - but the downloaded shaders needed to work in both DS4.0 and 4.5.

    I have at the moment daz studio 4.5 pro 114 .with Genesis Starter Essentials 1.4 I'm also getting - It should be recompiled for better performance when using the pwSurface2 shaders

    Also noticed slowness when loading materials, shaders and in render time

    should I install the beta version , will this fix this problems ?

  • Richard HaseltineRichard Haseltine Posts: 19,401
    edited December 1969

    No, the shader would need an actual recompile to fix the issue - and then it wouldn't work in 4.0. Though this should affect render speeds if anything, it shouldn't have much if any impact on load times (since the thing that gets loaded is the script to populate the Surfaces pane, not the actual shader used by 3Delight).

  • RedHeadLilithRedHeadLilith Posts: 0
    edited December 1969

    thank you for your answer, so could it be that the long loading time for skins got to do with the fact I moved all my items to d driver and not the regular c my documents path ?
    I also removed the c path from the content directory manager

  • Richard HaseltineRichard Haseltine Posts: 19,401
    edited October 2012

    I suppose that might be a factor, though if you removed the old path (and don't have a long list of other paths above the one you are now using) that should really be an issue only if the drive itself was slower. If anything I'd expect a move to slightly speed the process as you have effectively defragmented the files.

    Post edited by Richard Haseltine on
  • loserincloserinc Posts: 0
    edited December 1969

    mjc1016, or anyone else. Can you please elaborate on how to recompile. I have tried drag and drop the sdl on the shaderdl, both of them, the one in daz, then the one in 3Delight. I am still not getting them to work. I'm trying to use the pwsurface2 shaders, or do these just plain not work in 4.5?

  • mjc1016mjc1016 Posts: 7,247
    edited December 1969

    loserinc said:
    mjc1016, or anyone else. Can you please elaborate on how to recompile. I have tried drag and drop the sdl on the shaderdl, both of them, the one in daz, then the one in 3Delight. I am still not getting them to work. I'm trying to use the pwsurface2 shaders, or do these just plain not work in 4.5?

    It's a command line operation...open a command prompt and type in shaderdl.exe --recompile xxxxxx.sdl (in the folder where the sdl you want to recompile resides).

  • loserincloserinc Posts: 0
    edited December 2012

    It's a command line operation...open a command prompt and type in shaderdl.exe --recompile xxxxxx.sdl (in the folder where the sdl you want to recompile resides).

    I get an error: shaderdl: cannot open 'recompile' pWsurface2.sdl

    Just in case I am missing something, I'm running Windows 7 64bit with Daz 4.5

    Daz location is F:\Daz Studio, so the shader dl is in F:\Daz Studio\bin\shaderdl.exe

    the shader sdl files are F:\Daz Studio\shaders\shadername.sdl

    Post edited by loserinc on
  • SzarkSzark Posts: 8,763
    edited December 1969

    loserinc said:
    I'm trying to use the pwsurface2 shaders, or do these just plain not work in 4.5?
    Trust me recomling won't make much difference besides Pwsurface works fine in DS4.5.1.6 what troubles are you having?

  • Richard HaseltineRichard Haseltine Posts: 19,401
    edited December 1969

    How old is your pwSurface2 installer? The files needed updating to recompile properly so you may need to reset and reinstall.

  • loserincloserinc Posts: 0
    edited December 1969

    my version of the pwShaders2 is 1.2

    I did get it working finally, although it cannot find the jpg files, but at least some of the basics work, and I got the uber spot and uber point to work as well. I was just missing some parameters in the cmd line

  • SzarkSzark Posts: 8,763
    edited December 1969

    There are no jpg files included in pwSurfacet that I know of. For the texture related presets you need to own the original product

  • Type 0 NegativeType 0 Negative Posts: 0
    edited December 1969

    Is this something daz will fix one of these days or do we have to do it our self?
    My system usually takes about 3 minutes to recompile this stuff before it starts rendering.
    So when I’m setting something up and doing a dozen or so spot renders this really slows me down.
    I cannot figure out how to recompile this myself.

Sign In or Register to comment.
Rocket Fuel