Textures fail to load with .dsf Support asset/figure or prop • Daz 4 [Solved]

Hi, I've been stuck on this one for a while.

I've set up some new objects (Clothing and props) and I'm saving them as support assets .dsf files.

The user facing file created in the prop folder, loads all of the geometry and surface material settings but fails to load the texture maps. The objects are part of a product and I was wanting them to load with texture maps in place.

All the file paths in the def seem right and I get no errors when the file loads but no textures are loaded on the surfaces.

Am I missing a process here? Or doing something wrong?

Any help would be greatly appreciated.

Post edited by Design Anvil - Razor42 on


  • SzarkSzark Posts: 10,535
    edited December 1969

    I have asked other CV's if they can help so I am waiting to here from them.

  • Canary3dCanary3d Posts: 1,861
    edited December 1969

    Are the textures stored in the same library as the object & dsf? Or do you have multiple libs with textures stored outside?

  • Design Anvil - Razor42Design Anvil - Razor42 Posts: 1,119
    edited June 2012

    I'm on a Mac with OS X Lion running Daz Studio 4 Pro.
    I appreciate your efforts to try to help me find a solution for this one, its been driving me nuts.
    Everything is in the MyLibrary runtime in Documents

    User facing files

    Support files
    Morphs and UV sets also saved here.

    Textures are stored in
    Thats pretty much the structure I'm using for the product, there are multiple components/items.
    One main thing I have noticed my .dsf files are missing that is in a few others I have checked. is that there is a section before the material library statements called selection map. This is missing in the dsf files I create. Not sure if its important. This is in the dsf in data folder.

    "selection_map" : [
          "id" : "",
          "mappings" : [
    Post edited by Design Anvil - Razor42 on
  • Design Anvil - Razor42Design Anvil - Razor42 Posts: 1,119
    edited December 1969

    Okay, I think I have figured out was I was doing wrong.

    Daz Clearly doesn't like any spacing in the path leading to the textures.

    It seems to be okay in other places just not in the Texture resource paths.
    So this doesn't work
    /Runtime/textures/Design Anvil/DA Faery Pack/Clothing/Oak_Leaf_Red.png
    you can't seem to see the percentage twenty between them on the forums but its there in place of spaces

    And this appears to work fine.
    So I have closed up the gaps in the path and order has been returned.


  • Richard HaseltineRichard Haseltine Posts: 51,513
    edited December 1969

    Spaces should be replaced with - have you tried manually editing the path in the saved file like that? If that does work then it sounds like a bug in the save routine, not converting texture paths to properly formed URIs.

  • SzarkSzark Posts: 10,535
    edited December 1969

    Thanks for reporting back Castleworx. Certainly helped me, cheers.

Sign In or Register to comment.