Creating Genesis FBM in Blender

swordvisionsswordvisions Posts: 124
edited December 1969 in The Commons

I am trying to create a full body morph for genesis. When using morph loader pro - I get geometry does not match. I am using the Blender preset when I export from studio.

I move some polys around and then export obj from blender. I am checking keep vert order when I import and export from blender

I guess either my settings are wrong in blender when I import or export the obj or maybe its the blender preset that I need to tweak.

I know several of you use blender so any advice would be welcome. Thanks.

Comments

  • swordvisionsswordvisions Posts: 124
    edited October 2013

    After some more experimentation and and Google forum search I was able to test sculpt a morph in blender and bring it back into Daz, but I only looks right at 100% so I am still missing something.

    Below are screen shots from Daz at 0, 50% and 100%

    Thanks again for any help

    Edited to add: I am using Blender 2.67 and studio 4.5 pro

    morphset0.jpg
    609 x 280 - 17K
    morphset50.jpg
    547 x 300 - 16K
    morphset100.jpg
    596 x 284 - 18K
    Post edited by swordvisions on
  • Richard HaseltineRichard Haseltine Posts: 50,082
    edited December 1969

    Is the morph mirroring the mesh? That could happen if you have an axis set to invert in inport or export and not in the other direction.

  • swordvisionsswordvisions Posts: 124
    edited October 2013

    Not sure what happened. I upgraded my software to 4.6 and started over. It worked this time. I decided to create a little video tutorial showing my process.

    Creating a Morph target in Blender for Genesis

    I don't know if this will help anyone. There is no voice. I used instructional boxes. I may add some music later.

    Edited to add: I got my settings from jestmart which were posted in the thread Creating Morph Targets with Blender 2.6

    Post edited by swordvisions on
  • KatteyKattey Posts: 2,899
    edited December 1969

    After you imported the morph from Blender to DS you can export it as usual OBJ (say, Hexagon scale, 1 unit=1cm) and re-import it back to DS via Morph Loader Pro (same scale). This way you should be able to get a morph that behaves normally at 0-100%.

  • jestmartjestmart Posts: 3,610
    edited December 1969

    I am not sure what settings you are talking about but you must have missed the part where I said DON'T YOU BLENDER SCALE OPTION. It simply isn't right, use Custom at 100% and don't mess with any of the axis setting.

  • swordvisionsswordvisions Posts: 124
    edited October 2013

    That is what I did in the video. I used 100% custom. Maybe that was my mistake in my first attempt.

    Edited to add a pic of the morph in Studio

    morph100.png
    256 x 227 - 30K
    Post edited by swordvisions on
  • Richard HaseltineRichard Haseltine Posts: 50,082
    edited December 1969

    The scale doesn't matter when creating morphs as long as you use the same setting (inverted scales) on export and import.

  • SickleYieldSickleYield Posts: 7,316
    edited December 1969

    What he said. I'm actually still using Poser scale for everything on Blender import/export, including my character morphs, and it works fine. :D

  • V3DigitimesV3Digitimes Posts: 2,251
    edited December 1969

    Exactly the same for me. It works perfectly using poser format export / import preset in DAZ - poser.
    It fails for most other settings.

Sign In or Register to comment.